CSL pedals throttle issue

I bought CSL pedals from a guy who had bought the DD Pro but did not want CSL pedals. So this is new unused CSL pedals however he did not have the RJ12 cable so I ordered a new one from Fanatec Website.

My issue is after installing the drivers for the pedals and my clubsport usb adapter. When doing the function test only the brake pedal works and the throttle pedal was unresponsive.

I tried both 405 driver (recommended for this) and the 434 (the latest available) but they have the same results.

I tested in games same thing only brake works.

I also tried using another rj12 cable but same thing.

I noticed that the replacement rj12 I got from fanatec webshop looks different to the RJ12 cable the normally comes with the pedals. The original one has a ferrit core near the plugs. The replacement one I have didn't.

The online manual states to only use the original cable - so could this be the issue? Or the pedal is faulty?

I logged a support ticket already but still waiting to hear back.

Is it possible to buy a replacement original ferrit cored cable from Fanatec? Or can I purchase just a replacement throttle pedal?

Any ideas?


Sign In or Register to comment.