CSL pedals and Clubsport USB adapter combo


I've recently bought these very first Fanatec products and I've been having problems for 2 weeks connecting them I can't get my head around it. I have tried several driver versions, written to Fanatec technical support like 4 times already and got the adapter replaced, but still nothing. The very first problem when I got the products was when trying to update the USB adapter' firmware. It said "Error reading firmware file!", then I got onto my brothers PC and tried it there. I got past this part, updated the firmware but here's the next one. The pedals ain't working. At one point I had the throttle working but not the brake pedal. At the moment I am writing this post, none of the pedals work and clicking update firmware with the latest drivers seems like it crashes the whole thing. It plays a sound like you unplug an USB stick from your computer and it completely disappears from Game Controllers list.

Btw I don't know if something should appear in the Fanatec Control Panel but obviously it doesn't.



  • I might aswell get ready to refund them if no one else had this problem before, lol.

  • This is one of the same problems I'm having (in addition to a failed CSL DD & Universal Hub). Fanatec Control Panel doesn't recognize the pedals, but "sees" a shifter (which I don't have). Just received the USB adapter to update the firmware of the pedals and that didn't work either.

Sign In or Register to comment.