Pedals not working via RJ12 on PC or PS5, but works via USB on PC

Hi all,

I recently got a Fanatec GT DD Pro Premium Bundle with the boost kit and load cell add on. Everything has been working fine for a month or so, however just on Thursday the pedals stopped working in Gran Turismo 7, and every other PlayStation game.

  • I've tried troubleshooting the issue myself, including upgrading the firmware of the wheel (pedals were already up to date).
  • I connected the wheel and pedals to my PC via USB and both are detecting fine via USB.
  • However when I try to use the RJ12 connection on the wheel base to connect the pedals, the pedals don't detect on my PC.
  • Furthermore, when I try connecting the pedals to my PlayStation 5 via USB OR RJ12 the pedals never work. Is USB a supported method of connecting the pedals to the PS5?

Has anyone got any ideas of what might be happening here? I've tried replugging the cords and I noticed the "Pedal" RJ12 port is slightly loose. The cable fits firmly into it, but the port that surrounds it kind of shifts if I put slight pressure on the cable. Below are some photos showing the extremity of the flex.

I don't know if it's something that's to be expected, or perhaps the port is broken? If so, I guess RMA is my only option?




  • Port is broken.

    RMA time.........

  • Thanks Jon, yes my thoughts also. The other ports (shifter etc) are completely solid and don't move at all. This one moves around much more than I think it should. Strange as I've been very careful with the wheel in the short time I've owned it.

    I raised a case with support yesterday so lets see how I get on. It's inconvenient, but couldn't be better timed I guess as I'm going away for about a month or so soon. Let's hope that I can get it fixed while I'm away and it's back & operational mid-April some time ready for more GT7.

  • Hello,

    Same problem here, pedals RJ12 port desoldered for no apparent reason, and many other cases on Facebook

    I hope that Fanatec will take care of the repair quickly, on such expensive equipment, this kind of problem is not acceptable.

    My 850€ steering wheel is unusable as it is.

  • I just had the same problem. How did you fix it? No one from Fanatec has replied me since 4 June the day I raised a ticket.

  • The only way to fix it is to send it back to Fanatec under RMA.

    Fanatec`s support is a bit slow lately. Seems to be taking them a week or two to respond to service requests.

  • Yes, you have to wait for Fanatec to reply, it took 2 weeks for me, then another week between sending the base to the SAV and its return after repair.

    Don't hesitate to create several tickets if you need to and remember to include photos of your base.

    How did this happen in your case?

Sign In or Register to comment.