Clubsport V3 brakes flickering only when turning wheel?

Herman CHerman C Member
edited April 2022 in Pedals

So I just got my wheel up and running, and I'm running into an interesting issue with the brake pedal. No matter if I use automatic or manual calibration, if I turn my wheel left and right, the brake will indicate instant flashes to around 5-7% brake application.

I've tried manually setting a deadzone for the brake, but no matter where it's at, turning the wheel makes the brake pedal flash up. For reference, I'm using a DD Pro with these pedals. Everything is updated to the latest firmware (non-beta) including the pedals.

Edit: Also noticed that if I hold the brake pedal steady at any point and turn the wheel, the brake starts going wild with fluctuations. Stopping wheel movement makes the brake values calm down to what I've read is "normal" fluctuation.


  • I'm having a similar issue. Frequently, the Clubsport V3 Pedals will register a 1%-3% brake input value despite having my foot completely off the brake. Are you playing GT7?

  • No, I haven't tried it on the PS5 yet. For me, it's not a game-related problem, rather the inputs itself in the Fanatec software show this wild fluctuation when braking and turning the wheel. I can't tell if it's a pedal problem or not, but I'm also getting some clicking noises every time I press the brake pedal now and I've only started using it less than a week ago.

  • Dominic BrennanDominic Brennan Member, Administrator

    This sounds like a possible interference/grounding issue. Have you tried grounding your rig, for example by connecting a wire from a metal part of the rig to a metal radiator?

  • I don't have a radiator anywhere, but I have connected it to other metal objects that are grounded and it seems to have no effect.

    It seems to scale with FFB, if I have more natural damping on, turning the wheel makes the brake input spike more readily. I was able to calibrate out the undepressed flicker by just setting a dead zone large enough, but if the pedal is depressed, let's say half way, it fluctuates all the way from 10-20% to 80-90% and even to max. The fluctuations are super momentary, kind of reminiscent of the TC cut of older GT cars if you know what I mean.

  • Dominic BrennanDominic Brennan Member, Administrator

    That is very strange, I suggest that you open a support ticket, and please include a video that demonstrates the problem.

    [Fanatec Community Manager]

  • I have the same issue when I am driving and get up to speed on PC and PS4. I did the manual end point settings which fixed it for the most part, but it makes teh brakes not feel quite right. They go from barley slowing the car, to locking up at about 1/2 application.

    with the auto it was not this way.

  • BTW I sent an email 4 days ago.... silence

  • Dominic BrennanDominic Brennan Member, Administrator

    Hi kirby,

    I can confirm that your ticket is on the system. It's currently taking a few extra days between responses due to a high volume of enquiries.

    Regarding your issue, the manual calibration should not affect the overall performance of the brake. The BRF setting should still behave the same, so you should be able to get it to feel the same.

    [Fanatec Community Manager]

  • hey am having same issue with my new fanatec v3 connected to csl dd , on pc. when i steer it registes brake 2-5%. i assigned a 2% deadzone by setting min and max. did u manage to fix it? really weird :( :(

  • Same issue here and I need to put in a ticket in. Just received mine yesterday and updated it to the latest firmware. Tried it with the rj21 and then the usb with no luck in iracing and assetto corsa competizipne. I’ve tried setting the min. and max while turning the wheels and pressing lightly on the brakes and still flickering but not as much(still 1-2%). Most noticeable in game when it brakes automatically when turning without braking and it just slows my car down. The flicker also shows up in motec telemetry as micro brake flickers. I have the latest update and firmware as today. I’ll also try to keep you all updated if anything else works for me before putting in a ticket.

  • Eric ImEric Im Member
    edited April 2022

    So under the “Tuning Menu” and “device setup” I went from “advanced mode” back to “standard mode” and also went back to “auto setup”. That eliminated all the flickering from both the brake and steering inputs just now. “Standard mode” + “Custom” setup will result in the same brake flickering. So try going back to all factory defaults in the software for now or use the tune menu sparingly with minimal adjustments to ffb. This is very odd as I never thought that the steering FFB and steering input would have an effect on the brake inputs. This also happens on the non loadcell brakes.

    Update 1: Still happens from time to time but would have to go through the procedure above again as well and unplug/plug back in all the usb devices.

    Update 2: Brakes will still flicker on brake input but not excessively as before (still playable) and no flickering from only the steering inputs. Flickering would be worse with more preload tension on the brakes as well.

    Update 3: So I tried the “Custom Setup” but after going through the reset cycle above so I can change my steering angle, ffb strength, and natural damper and it seems to work okay for now.

    TLDR: Try going back to all default/standard/auto setup on the force feedback and it may help temporarily.

    DD Pro Set

    CSL Universal Hub

    Clubsport Pedals V3

    Boost Kit 180

    PC Driver 439



    Wheel base motor:

    Wireless QR:

    Pedals: 1.32

  • Hey man, min is only flickering 2-5% when apply steering. If i add dead zone regular steering (without braking) wouldnt cause any flickering but once i brake and steer u can notice a bit of steering. They say it could be emi or even driver issue. Sometimes if i restart the pc all works perfectly untill again it happens randomly. So i just kept the dead zone (playable) but dont know what is the cause

  • Most likely a driver or firmware issue. If my steps above didn’t work try using another wheel base from a different brand. I tried just that and had no issues w/ steering input causing the brakes to trigger and flicker. I still get minimal brake flicker from the clubsport v3 but as you’ve mentioned setting the dead zone manages that.

  • Do u think there is a way to downgrade our driver from 439. I dont have another base rightnow, my csl dd still new, was planning to sell it and get a dd pro, but since same issue wouldnt make any diff. If u have any exp in downgrading the driver pkease update me

  • Eric ImEric Im Member
    edited April 2022

    I tried this. Went back to the previous driver but I was still able to repeat the flickering issue while pressing the brakes and applying steering input. It all just ended up with the flicker. Now I just set the dead zone while i press the brakes and applying steering input left to right. Aahah It kinda helps.

    I have not gone back to a previous firmware though as I do not want to brick my device after it being successfully updated to all the latest firmware. LOL You can do so “manually” through the driver software but at your own risk I guess. If it gets worse I may just put in a ticket because it’s like this with the non clubsport pedal on my GT DD Pro (the new csl pedals it comes with as a kit). Same issue with the 5nm power brick. Not sure if it’s the wheel base or the clubsport pedals now as i mentioned i had the same issue with the non load cell brakes the dd pro came with. or it could be the drivers. i have no idea now and about to just give up and put in a trouble ticket after the weekend of more in-game testing.

  • I found a solution :

    try disconnecting the base from ur rig out on ground and connect pedals usb. And try ull not notice flickering. When u put back on rig it will flicker.

    so what i did was :

    put electric tape on the T nuts , and under the T nuts from the base side. Two layer of tapes so when u bolt it the bolt wont hit the metal. Do this for the two bolts on three u wanna use to bolt the base. Then on top of rig ( where u mount ur base) put a piece of strong cartoon to prevent touch of base lower part (metal) with the rig.

    then mount them. In this case u prevent the T nuts touching the metal of the base, u prevent the bolts touching metal of base and prevent lower part of base touching the rig. Restart ur pc . Turn them on and should work.

  • Eric ImEric Im Member
    edited April 2022

    Thank you! Holy moly so it was an EMI issue. I didn’t go though all your steps to isolate the wheel base with electric tape plus placing a barrier between the rig and the base but instead just ended up using the plastic desk mounting kit it came as the non-metal contact. LOL I will need to give your technique a try as i don’t like the flex with all that torque i can finally adjust without it affecting my brake inputs. Thanks again!

  • Hahaha am happy we sorted it out, lets try a side mount i guess we have to remove any metal with meta contact. For me i dont have a plastic clamp so i have to use the T nuts. But still better than before. Cheers

  • the issue with the flicker from the brake pedal is that the Automatic preset cannot be used as the manual calibration is then disabled.

    That is not right

  • Dominic BrennanDominic Brennan Member, Administrator

    Auto Setup unfortunately doesn't allow you to use BRF, but it should not disable manual deadzones that you've set.

    Using an RJ12 cable with ferrite cores or some form of rig grounding could solve the flickering problems in general, but if you have unusually high EMI problems then the manual calibration might be the only option to avoid that, and you'll have to not use Auto Setup if you want to adjust BRF.

  • yes, auto does still cause the Flicker if I switch to that mode on the wheel. I have a reply to my ticket today from Fanatec CS. I will report back if that fixes the problem.

    EMI would imply that the base is generating a lot of electrical noise when it is operating or the sensor in the pedal is poor. In any case, noise should be dissipated through the power cord grounding.

    I am using the RJ12 connector to the base.

Sign In or Register to comment.