DD1 interference with HTC Vive Pro and Valve Index Headset Tracking

I've got 2 DD1's that have this problem. 

 When using either a HTC Vive Pro or a Valve Index VR headset, the headset tracking drops out ( headset video goes grey) when I touch the sides or bottom of the VR headset when I'm sitting in the simulator. If I turn the power to the DD1 off, the problem goes away. If I stand up and move a few feet from the DD1, the problem goes away. This makes it impossible to adjust the IPD or the headset position while the DD1 is on.

Anyone else seeing this?


  • Is your rig properly grounded?
  • edited September 2019
    I think you are on to something Maurice. 

    All electrical connections are properly grounded but the rig chassis itself is not tied to ground and in fact is isolated from the non-conductive carpet with a rubber mat. So I guess you'd say the rig chassis itself has a floating ground. Now I just tried stepping off the rig with the DD1 powered up, and held both sides of the VR headset. Tracking was as expected, normal. Then I simply touched the rig chassis and the tracking dropped out. I can repeat this consistently. So, over the weekend I'll run a copper grounding wire between the rig chassis and a cold water ground. That should tell the story.

    I'll let you know what I find. 

  • Grounding the chassis, or even directly grounding the DD1 to a cold water ground did not solve the VR headset tracking problem. 

    However, I found that if I disconnect the DD1 USB cable, the VR headset tracking is fine, even with the DD1 powered up. So this looks a USB issue. 

     I've tried different USB 3.0 and USB 2.0 ports for the VR headset and the DD1 and the symptoms do not change. Next, I'm going to try adding the Inateck HT5001 PCI-E USB 3.0 expansion card that includes a 15 pin power connector. Rumor has it that this card has helped solve HTC Vive Pro and Valve Index headset tracking issues. 

    I'll let you know how that works out.
  • Happy I could dig into the tricks I learned in the Navy as an Avionics Tech. The problem was a ground loop. I added a ground isolator to the USB connection between the DD1 and my computer and the VR headset tracking problem is no longer an issue. Watch out for ground loops when you've got a ton of stuff connected to your PC through the numerous USB ports.
  • edited January 2020


    I'm having the very same issue with the same configuration (Valve index + Podium DD1), I don't know how to solve it, already get in touch with Steam support wihtout results, I tried all the troubleshooting they proposed.. I also tried to use a USB isolator without any result.. do you guys have any clue of how I can solve the interference issue? Is there a USB device that could work?

  • I reported the problem solved back in September by using a USB ground loop isolator on the DD1 but that was optimistic. It was better, but not resolved.

    Try disconnecting the Clubsport pedals from the DD1 wheel base and see if that helps. I understand that is probably not a solution for you but it might help Fanatec to isolate the problem. I replaced my Clubsport pedal set with a Heusinkveld Ultimate Pro set (which uses it's own USB port) and while the problem hasn't completely disappeared, it is significantly better. At least I can adjust the IPD and I never lose tracking when racing.

  • Robert first of all thanks for your feedback!! I already tried to disconnect the clubsport from the steering wheel and connected to the PC USB port but the problem is still there.. how a different pedal unit could mitigate the issue? I think it’s caused by the force feedback unit, so the only way to get it solved it’s to change to a different steering wheel (sim cube??). Furthermore I still do not understand the reason why this issue seems to be not so common, I just found your post... are you aware of any other forum/community where to discuss about it? I don’t see Fanatec is interested in getting it solved...

  • I have the same problem with DD2 and valve index with base stations version 1. Is any one with the new base stations got the same issue?Anyway i order some ferrite chokes from amazon and i put them all over the vr and wheel base cables but nothing happened so I start cheking with handhield ham radio on what frequency will get interference and so far its under 1 Mhz so I order ferrite chokes mix 75 and in next few days ill try to sii if they do the magic.The fanatec support told me to try grounding my cockpit. Is that gonna help in any way and feom where to make that ground connection? Is the paint not like isolation between the different elements.Its simetik k2 by the way.

  • As noted in my previous comments, I grounded my rig and the DD1 to a cold water ground and that did not make a difference. Replacing the pedal set did make a big difference (I rarely notice it now) but didn't totally eliminate the problem. FYI, I'm using the base stations that came with my HTC Vive Pro, which exhibits the same problem.

  • I have this problem too, I have a valve index but with HTC vive base stations does anyone know if i buy the valve index base stations will they work ok??

  • Robert did you get rid of the problem?

    I got the same thing happening on my rig. Cant play with vr since i got my dd1.

    And Svetlin can you tell me some more ferrite's and where exactly you installed them?

    Tnx in advantage

  • edited May 2020

    I install them right next to the wheel base.Two loops on the power cable and after that two loops on the usb cable.You can see the headset cable is right next to them and no issues for me at all.The grounding is recommended by Fanatec support.

  • I am no longer experiencing this problem. Possibly the latest Steam VR drivers are helping. Only changes I made were replacing my Fanatec Clubsport V3 pedal set with Heusinkveld Ultimates and I am now using a wired gigabit ethernet connection to my router. My previous connection was wireless. Valve Index is rock solid now.

    I've been running with the HP Reverb Pro for a while (higher resolution) , which displayed none of these EMF issues but the headset was really uncomfortable and I had trouble with fogging. Colors were also washed out. I switched back to the Valve Index today and not only is it more comfortable, colors are much richer and my lap times dropped significantly. Kind of amazing how this minor change affected my overall comfort and lap times. I must have been subconsciously distracted by the comfort level of the HP headset. I've also gotten used to the higher refresh rate of the Index.

  • Thank you Svetlin, i'll give the ferrite's a go. Allready tried grounding the wheel base but that did not help for the tracking issue.

  • edited May 2020


    Hey guys,

    I could not wait for the ferrite's to arrive, so i thought of trying something.

    I am running a homebuild motion sim with truck wiper engines. Had them powered trough propper size cables but without insulation(like a coax). So i removed the power cables and replaced them for coax cables witch have much better isolation.

    Also i ran the hdmi cable towards my htc vive through a ferrite from a old amplifier. Winded 3 times.

    It now fixed the issues for me and i can drive the motors a lot harder without getting tracking loss!

    So for now i will have to buy some proper wires with isolation for powering the motors!

    And btw, i removed all earthings from my steel rig.

    Tnx guys for your help!

    And robert i would love the heusinkvelds but i just got my v3's😅

Sign In or Register to comment.