V3 Pedals not recognized after Latest Windows 10 Update

I Have tried numerous Drivers from 340-345, and the "Official" Drivers, 311 and 328. The pedals are not recognized despite what USB port I try (13 ports total). 340 was working fine until the windows update today (9/13/2019).

All other peripherals work in every USB port.

Please advise.



  • Joseph GossenJoseph Gossen Member, Moderator
    edited September 2019
    Why are your pedals not plugged via wheel base?
  • Just verifying that the pedal still work by connecting them to the wheel base would be good, and if they do then we should dive into the USB connection.

    Did you properly uninstall driver - restart Windows - install new driver version - restart Windows while testing? Are you installing the driver with the pedals connected through USB? have you tried the 'repair driver' function of the Fanatec driver?

  • edited September 2019
    As a funny coincidence, my Win10 PC updated today and afterwards (after multiple system restarts), when I started the Fanatec driver and double-clicked the CSP v3 device to take me to the pedal functions, the driver would not initialize and the pedals disappeared from the device list in the Game Controllers window.

    I then uninstalled the Fanatec driver, restarted Windows, installed driver v340, restarted Windows and all was well again.
  • How did you go in resolving this?

    I have a very similar issue. V3s not recognisable on my new windows 10 via USB; tried all ports updated drivers. still nothing.

    However the pedals are functional on my windows 7 laptop with no problems, only they arent recognisable when trying to manually update them.

Sign In or Register to comment.