DD1 causing RF2 and iRacing to CTD

As the title says since today 20th September 2019 whenever I load up RF2 or iRacing with my DD1 powered on with the F1 2019 rim both games CTD.

If I power off the DD1 then the games load fine.

Anyone help?


  • Have you tried to uninstall and re-install the Fanatec driver? A Win10 update may have installed which is known to mess with the Fanatec driver.

  • I have exactly the same problem. Sometimes Rfactor2 will just crash and it gets me back to the desktop and somethimes I will get a blue screen. And Windows will start working again after 30 seconds. This has not happened before, however, since 3 days I cannot use the wheel anymore. I even reinstalled Windows today, however, still the same problem. Fanatec, any advise? Are you aware of this problem?
  • Well I managed to fix it yesterday.  I removed the F1 2019 rim and put the porsche rim on.  RF2 and iRacing no longer crashes.  I then put the F1 2019 rim back on and now all is good.

    Not sure why this fixed my issue apart from maybe a loose contact between rim and base or WiFi issues as I know the rim talks wireless to base?
  • I just updated to the latest beta driver and while this seems to have helped slightly, I still get blue screens and random Windows shutdowns from time to time. I initially thought it might be related to SteamVR, however, deinstalling it didn’t help, so I am pretty sure it is somehow related to the Fanatec driver or firmware.
  • Marcel PfisterMarcel Pfister Member, Administrator
    Please add more information when you report issues:

    Type of Wheel Base:
    Type of Steering Wheel:
    Type of Pedals:
    Driver Version:
    Base Firmware Version:
    Motor Firmware Version:
    Steering Wheel Firmware Version:

    Otherwise we can't test and compare or make assumptions from multiple reports where the issue might come from. 
  • edited October 2019
    Please see my config below. Will have to get in touch with support tomorrow to ask for a replacement DD1. 

    After two weeks of trying everything to get my base to work I give up. I reinstalled Windows, tried 4 different Fanatec drivers and firmwares, tried different NVIDIA drivers, turned of SteamVR and even tried my old T300 wheel. I am now certain that it is the Fanatec wheel that causes my PC to restart, shutdown or blue screen every time I try to play Rfactor 2. It also happens when I am in Windows without Steam any other game even running. I hope Fanatec support will provide me with a timely replacement.

    Type of Wheel Base: DD1
    Type of Steering Wheel: Porsche 919 and McLaren GT3
    Type of Pedals: Fanatec Clubsport V1
    Driver Version: 346 (tried 347, 345 and the official driver as well)
    Base Firmware Version: 662
Sign In or Register to comment.