Wheel Base v2 not recognized?

Hello guys, i hope i'm in the right place to ask for help. So, i have a Wheel Base V2 and it was working fine, then i've opened the wheel driver to set everything ok, and the software told me there's a new firmware update available, so i've updated it, like all the other times. After finishing the wheel restarted as it usually does, BUT the display on the wheel did not turn on, the pc is not recognizing it anymore and i can't turn it off normally from the "start" button. Does anyone know what happened and how can i solve it?


  • So the firmware installer finished without errors/problems?

    What happens if you press and hold the power button, does it start in bootloader mode (blue LED)? If yes, then you could install an older firmware through an older driver (uninstall current driver, install older driver, start wheel base in bootloader mode, install firmware).
  • Exactly, firmware installation finished without any errors. If i press the start button the wheel powers up, starts rotating to one direction, then to another one, as it always does, and the led remains red (pc mode) as it has to, but the display on the wheel remains off, and i cannot interact with the settings of the wheel, like FF, SEN, etc.
  • edited October 2019
    What rim are you using?
    Also, please state what driver and firmware versions this is happening with.
  • I have the CS Universal Hub, the driver was the latest but i don't remember if it was the 328 or 311, and i don't know which firmware version was on :(
  • This is my hub and wheel base
  • Then try the latest beta driver to see if that gets the wheel base going: https://www.fanatec.com/forum/discussion/1058/fanatec-beta-driver-v347-for-csl-csw-all-wheels#latest.

    Uninstall current driver
    Restart PC
    Install beta driver
    Restart PC
    Switch on wheel base

    If it's not recognized, switch off wheel base, then press and hold power button until it starts in bootloader mode (blue LED).

    If your PC still doesn't see the wheel base, try again without the uHUB attached.

    If after that it's still not working, it's time to contact Fanatec Support.

  • Ok, bootloader mode works, flashed firmware after installing the beta driver but still have the same problem, maybe i have to flash a different driver?
  • maybe i have to try with an older version?
  • maybe i have to try with an older version?
    You could try v328 again which is the official latest driver found on the CSW v2 product page, but you already tried it and it gave no errors. It's strange that your PC doesn't recognize the wheel when starting up, but it does make a connection when in bootloader mode. 

    Did you try swithing on the wheel base without the uHUB attached, to see if the wheel base connects to the PC that way?

    If not, then I would recommend contacting Fanatec Support as a repair may be in order.
  • what is the uHub?
  • what is the uHub?
    Universal HUB.
  • U ARE MY MAN ❤ turning it ON withou the uHUB solved the problem, thank you so much ❤❤❤
  • U ARE MY MAN ❤ turning it ON withou the uHUB solved the problem, thank you so much ❤❤❤
    So then after switching on the wheel base you put on the uHUB and it was working OK?
Sign In or Register to comment.