CSL Elite Pedals (+ LC) Not Connection


I just received my CSL Elite pedals and the LC kit. Running PS4, and have updated all firmware. CSL Elite Wheel Base+ and F1 2020 wheel.

After installing the LC and assembling everything, I plugged in the LC brake and Gas (not using the clutch).

Now, the LC brake is working fine. But the gas not so much. The control box registers that a pedal is plugged in. But there's no input when pressing pedal.

I then installed the update software on pc to see what was going on and as expected it registered a pedal is plugged in, but nothing happens when pressing pedal.

I have tried to bend the cable in all sorts of ways and by pure luck it worked for a short while, about 4-5 laps of Red Bull Ring, before loosing connection again.

Wire was not caught and pinched during installation. It seems the connection is loose, either somewhere in the cable or in the RJ12 connector.

Anyone else ever experience this?

PS. Already sent in a support request.

Sign In or Register to comment.