CSR Elite Pedals V1

edited July 2020 in Pedals


I have a set of Fanatec CSR Elite V1 pedals which I bought together with the Forca Wheel back in the days.

Recently I switched my wheel to a CSL Elite 1.1 base with a Formula V2 rim.

The pedals were always connected to the Forca wheel as long as I used it. Now I connected the pedals directly to the computer via USB cable. Sinde that day I have troubles. When using the property page everything is OK. Wen entering a sim like iRacing, also everything is OK when checking in the options menu. But after some driving the throttle does not get up to 100%. It responds to all the throttle way but the max. reachable position is around I guess 93% max.

I thought OK the pedals are quite old and used regularly so the potentiometer is faulty and I ordered a new one. After changing and some testing the effect was the same. So I checked on the internet and found some postings where it was recommended to switch the PCB. I ordered then a PCB and changed that, too. But still the same.

Things I also tried:

  • deleting all drivers and install new
  • using latest driver and beta driver
  • changed USB cable and ports

Now I am out of ideas but before writing a ticket to Fanatec (I think they are still really busy due to Corona situation) I thought about giving the forum a try.

So is there anyone with the same experiences or just has a solution to my problem?

I really like the pedals and want to keep them, so I hopefully someone can help.

Thanks and best regards,


Sign In or Register to comment.