Need Help with my DD1

Hi there,
I have a problem with my Fanatec Dd1 wheelbase.
As soon as I start the fan runs at full speed, the base only recognizes the pedals and the steering wheel. after checking the firmware i noticed the motor firmware is on 0 and i can't update it when i press update motor the program closes and nothing happens. I have been using the wheelbase for 8 hours and now I have problems.


  • Andy MillerAndy Miller Member
    edited January 2020

    I have the same issue with my DD2. I tried troubleshooting with fanatec, but have been unable to get it to update past 0. I've requested an RMA for mine, but still waiting to hear back...

    They had me try the below... maybe it will work for you.

    1: Uninstall the Fanatec driver from your system in programs and features.

    2: Uninstall all devices in the device manager under Fanatec (Show hidden & show by container)

    3: Deactivate ALL antivirus software including Windows defender.

    4: Check for Windows Update. If there any available, please install them.

    5: Download the driver 347. If you already have downloaded, please download it again.

    6: Install the driver 347.

    7: Reboot your system.

    8: Please try to update the wheel base firmware first in the property page.

    9: Please try to update the Motor firmware second in the property page.

    10: If the issue is still present please don't power off the wheel base. Go to this location

    C:\Program Files\Fanatec\Fanatec Wheel\fw and run the FwBaseMotorUpdater.exe

  • Hello Andy,
    thanks for your help, i switched on the wheelbase this morning and then it calibrated i was able to carry out the update afterwards. do you think it can be on the steering wheel or should the update go without the steering wheel? since my Lebkrad was not recognized by the base.
    Best regards

  • Hi,

    Do it without the wheel, cause after updating your motor firmware you will have to calibrate the motor, and this needs to be done without wheel, so update everything on base first, calibrate, than proceed with wheel.

  • I have the problem driving again for 2 hours, now after a break, I tried again, but everything you wrote can no longer update the engine.

  • So you got yours to update, but now it has reverted back to 0 without any changes?

    I get the same error too, but it also changes to:

    Error: Connect device failed(Error: UartPeripheral() cannot open PC UART port(), speed(19200 Hz).).

    If I have my Valve Index hooked up it reads it as:

    Error: Connect device failed(Error: UartPeripheral() cannot open PC UART port(COM4), speed(19200 Hz).).

    I think the issue is with my DD2 as i've tried everything...

  • exactly after my break i restarted the wheelbase after that it did not calibrate itself anymore and the version of the motor update is on 0 since then i can no longer update the motor and the steering wheel is no longer recognized. I tried everything, unfortunately I can't get any further.
    I think there is a problem with the DD1 and DD2 Wheelbase or the firmware does not fit

  • Sorry to hear yours is having the same issue as mine. I'd put a support ticket in right away if you haven't already. It doesn't seem like Fanatec has a (Patch) fix available for this, so i'm sure it will be RMA. Maybe its faulty hardware...

  • very strange I leave the steering wheel off about 8-12h and then switch it on everything works as normal the firmware is on it and I just have to calibrate the steering wheel again

  • the only funny thing is the fan runs at full speed.

  • I can now describe the problem in detail, the base does not lose its update because I switched it on after a 12 hour break and it worked, everything was back to normal. now i drove about 4-5h and then the base suddenly went. it is the same problem again according to the program my motor driver is at 0 i bet if i turn the wheel off again for 8-12h it will work again.

  • Something is faulty, that's not normal behavior...

  • it must be a technical problem otherwise I can not explain it to you I hope fanatec swap the devices quickly in this case and give something as compensation as it is new and defective.

  • We can only hope. I'm waiting on response from Fanatec support on how to proceed with my RMA.

  • I've got the same issue with mine. Support have been utterly useless. Not impressed.

  • Did anyone here get a response on how to fix this? Seems like their quality control is pretty shocking tbh.

  • Exactly the same issue I have, my DD2 is a day old.

  • Has anyone had any luck at all with this? I have put in a ticket with support but still haven't heard back.

  • @Dan Webster @Adam Patarino: Has anyone got a resolution with Fanatec on this issue? I am still within my 14 day withdrawal and honestly speaking ... if this shit is going to keep happening then I don't need this half-cooked expensive piece of crap ... If anyone can confirm that Fanatec was able to fix this then please let me know. It will be greatly appreciated...

Sign In or Register to comment.