Clubsport Wheel Base 2.5 Malfunction

I've been using the Clubsport 2.5 wheelbase with peripherals for about 4 months, and it has performed flawlessly...until now. In the middle of playing F1 2017 a little window popped up and said a controller was disconnected. The start button on the wheelbase turned green and a small white light at the bottom of the wheel illuminated. The driver is no longer recognized in Device Manager (windows 10 PC) and in the 'game controllers' window it says 'controller.....status' and nothing else. I've changed the USB port, checked all connections, reinstalled the driver using the 'repair' option, restarted the PC 3x and the problem remains. I filled out a trouble ticket on the Fanatec website and am waiting for a response. I called the LA number +1 (866) 292-6226 and the robot said: Technical support is unavailable. Customer service is unavailable, and the mailbox is full so you can't leave a message. You can call England and talk to someone between (I get a one hour window) if you want to spend a fortune in phone charges. That person will probably be unavailable also because the loo was out of toilet paper and he had to run to the store. Oh, and thank you for contacting Fanatec. I am very upset. What kind of company is this? How does one talk to a person to correct this problem? I spent $1300 bucks on this package (which works very well...when it works) and this is the treatment I receive? I would be very grateful for any suggestions from anyone, company lawyers excepted.


  • Best thing is to open a support ticket through your account on the Fanatec website.

    One suggestion: try and connect the wheel base to another PC with the Fanatec driver installed, to make sure it's not something local on your PC. If possible, also try another USB cable to rule that one out.

  • I opened 2 support tickets and am waiting for a reply. I already tried connecting through another pc and tried different cables and different USB ports. I have reinstalled the drivers and firmware to no avail. Starting the wheel the display I get is:

    The start light blinks red around the perimeter of the button - clockwise.

    The wheel center lighting strip shows the number 8 in the bottom half and a white light on the top half. No button will change the display. The wheel is obviously out of calibration too as it sits about 30 degrees left of center and goes to that position every time I start it.

    Opening the game controllers window shows that the status is OK for both (HA they joke)

    Going to the function test page there is a red circle with a line through it over the pic of the wheelbase, and nothing can be changed.

    The lack of support by this company is frustrating and inexcusable especially considering the cost of their products. Even Thrustmaster, as much as I was disappointed by their wheels, had the courtesy to get right back to me and work with me in fixing the problem I had with them. The utter silence I'm receiving from Fanatec is infuriating and intolerable.

  • I'm having the same problem. Just pooped out a few days ago exactly as John described it all the way down to it happening after four months of owing the setup. Started a support ticket and same nada with that so far. This was my first stop here. Hopefully I'll find the answer here somewhere. Ja hopefully. >:)

Sign In or Register to comment.