CSW 2.5 PC driver issues

I have been using release driver 328 all the way up to beta driver 352 on an older AMD system with no real issues what so ever. I recently got a new computer (AMD 3700/Radeon 5700XT) and now i am having issues with the FFB. In iRacing, it would either lose all FFB or it would suddenly turn all the way left and act like that was center. Nothing would fix it except to turn off the the wheel and turn it back on. So I tried the wheel on my xbox and it worked perfectly in Forza 7 so I narrowed it down to a PC issue. Today confirmed that. I installed the PC version of Forza 7 and the game refused to load with the wheel in PC mode. As soon as I shut off the wheel or put it in xbox mode, the game would continue to load with no issues. I stayed in xbox mode and played the PC version of Forza with no issues. As soon as I put it back into PC mode, the game would basically pause/lock up but work instantly again when I turn off the wheel or go back to xbox mode. This is very discouraging and exactly the reason why I stopped playing games on the PC. I no longer have the patience to work through the amount of issues. I am hoping this is something minor that someone had run into and can help. I know the CSW doesn't seem to like USB 3.0 very much but this computer only has 3.2 and up USB ports. The board supports 2.0 but no USB ports are available. I need to get a USB board to hook up to the USB 2.0 headers but I don't have one right now. COuld it be something that simple?


  • So I connected a USB 2.0 bracket to the USB 2.0 headers on my ASUS TUF Gaming X570 Plus motherboard and tried playing iRacing. It worked and I no longer experienced any of my previous issues. I also tried Forza 7 (PC version) and it was working now as well. I assumed I had fixed the problem.

    That lasted for about 24 hrs and now I am experiencing the same problem again. I have tried every variation of driver/firmware, every single USB port, messed with RAM timings, changed video drivers and checked for other obvious errors and stuff in device manager. I am not seeing anything that sticks out as a problem. I even reconnected my old computer and played some iRacing on that just to make sure the CSW 2.5 didn't somehow fail. It works great on the old system, just much lower graphics quality and a crap ton slower than the new system.

    I am simply at a loss for what could possibly causing this issue. I have not experienced any other problems except this which is the worst case scenario since playing racing games on the PC is the primary reason I purchased a brand new top of the line AMD computer.

  • edited January 2020

    Are you sure that all kinds of USB power saving options have been turned off on your new PC?

  • David PhippsDavid Phipps Member
    edited January 2020

    Thank you for replying!

    No, I did not manually tun off anything. But, on the old computer I have never turned off any power savings either and no problems on the old computer, and both are Windows 10 PC's. However, on the old PC I had the power saving mode set to Performance and on the new PC I had it set to Ultimate Performance mode. I don't know if either one of those turns off power savings options for USB. I can certainly check tonight when I get home though. That said, manually turning off USB power saving features isn't something I would expect an average user to do but I seem to be the only one having this problem....ever. I have searched and searched the web for people with similar issues and I can't find anyone with the same problems.

  • So I turned off any power saving stuff for USB. I also had purchased some new ram modules. I was using some cheap Geil 16 GB and decided to get some Crucial Ballistix Sport ram with better timing. I also changed my power mode back to Ultra performance. Not sure if it was the settings I changed or the new memory or combination of both but I was able to go at least 2 hrs with no FFB problems. I am not getting my hopes up to much as I have had this false hope twice now (when I changed to USB 2.0 ports and when I reinstalled Windows) so I am going to be optimistic but cautious. I will see tomorrow if it's still problem free or not. Thanks for the tip though, it might have been the problem.

  • In my (limited) experience the pre-defined power saving modes in Windows do not touch the USB power saving option, so you have to set that separately. And yes, it seems odd that when actively using a USB device Windows will decide to shut it off, apparently 'using the device' has a different meaning in Windows than it has to us human beings.

    It's a known issue, though, for devices like steering wheels, meaning that the user has to switch off USB power saving to prevent the wheel getting disconnected. Hope your problem has now been solved with this!

  • Looks like it has been officially solved. I played again last night with no problems at all. I am not sure what the actually fix ended up being since I had done multiple things including the USB power saving options being turned off and swapping out my ram. One of these days I might try and reverse some of the things I did to find out what actually solved it but right now I am just going to enjoy the fact that I didn't waste over $1000 for a new PC after all. Thanks again.

  • edited January 2020

    Good news!

    I'm pretty sure that the USB power saving stuff was the culprit, but I'd like to know it if I was wrong 🙂

  • Well, here is an update. I will try to keep it short.

    Everything has been good for the previous couple of days so last night I decided to try and clock my ram from 3200 to 3600. The overclock was working fine. Jumped into iRacing and after about 2 min, I lost FFB. No big deal, it happens. So I restarted the wheel and iRacing. Within the first turn the wheel lost FFB and wanted to turn hard right. So, my issues were back again. Verified that when the game didn't want to finish reloading until the wheel was turned off.

    So I set everything back to stock in the BIOS so the ram was running at stock speed like it was and tried iRacing again. Problem still existed.......At this point, I just wanted to toss my computer out the window along with the wheel. So I started looking through the Device Manager and noticed that, even though my motherboard supported USB 2.0, and I connected the wheel to the 2.0 port, there was nothing under the Universal Serial Bus Controllers to suggest I had a USB 2.0 port. All I saw was USB 3.0 Root Hub and some other references to 3.1. There should have been a Generic USB Hub listed but there wasn't. I noticed this before but thought it was just something the newer computers did not show in how it was implemented. It would still show up under Human Interface Devices as USB Input Device when the wheel was turned on and i knew I was on a USB 2.0 port based on the manual from the mother board so I ignored it initially.

    Then I got to thinking that maybe it really isn't being recognized correctly or not truly USB 2.0. On a whim, I decided to connect a powered USB hub that I was previously using on my Xbox, to the "USB 2.0 port" on the new computer. I heard the computer ding and checked the Device Manager under Universal Serial Bus Controllers and low and behold, I now had a Generic USB Hub listed! Connected the wheel to that, jumped into iRacing and not a single issue!

    I really don't understand the problems that this wheel has with USB ports but to me, it's a serious one. I know I thought the issue was fixed previously but this time, I really think it's a real fix. I even went back and overclocked the ram to 3600 and tried playing iRacing again and I am still not having any issues. Not sure why my motherboard says it has USB 2.0 ports but they are not appearing as USB ports.

  • Just an update for anyone curious. My problems have so far not come back since using an external USB 2.0 hub. I have played Forza 7 (PC and Xbox), Forza Horizon 4, iRacing and ATS. I have also since OC'd my CPU, Ram and Video card. Currently using driver 347 with motor firmware v20.

    If anyone is having weird issues with their wheel make sure you are plugged into a USB 2.0 port. To verify on newer motherboards (not sure what to consider newer vs older), check under Universal Serial Bus Controllers in your Device Manager to see if Generic USB Hub is listed or not. If it's not, then it's most likely not correctly identified as a 2.0 and you will either need to get with the MB manufacturer, or do what I did and get an external USB 2.0 hub and plug it into the "USB 2.0 port" on your MB.

  • Wow now i found someboddy that do think where the Hell is he dowing with his pc samething and ALSO Lost my pedalenset inverted v3

    don t even now is being reconised by wheelbase or pc anything i TS is now like the v3 is NOT connected or has no hardware mb or software or is broken from that moment on

  • I am having a similar issue with a rather old game (GRID 2008), and did try a bunch of different ports and such. Alt+tabbing out of the game makes the pulling stop. Is it sometimes the game? If so, will just give up on the particular game and go back to a gamepad on it.

Sign In or Register to comment.