ClubSport V2 Pedals acting up

Okay, so this is starting to really frustrate me. I have a problem, since the last winter, where I stopped simracing because of it. Now I really want to get back to simracing but this is preventing it.

Basically, when I start my wheel base, everything works fine. The wheel references, I press all pedals to see if they work, everything fine. After a while of driving, the acceleration pedal starts acting up. When I go full throttle, it should be doing 100% ingame, right? Well, after a minute or so it only does 99%. A corner later, it only gets to 98%. And so on, until it only reaches around 85%. I did one fast lap on Baku Circuit, and on the second lap I was already 1,7 seconds off because of the pedals not giving me the full throttle. Additionally, the acceleration acts up - the gauge goes up, but jumps around a bit. It's hard to describe, I might do a video next time around.

I am getting really frustrated. The pedals alone cost more than a G29 wheel, and I've never had such problems with that one. I've tried updating the firmware of the wheel and wheel base, I've tried cleaning the pedals and sensors and fastening the screws, but nothing helps. I might try switching the sensors of the clutch and acceleration pedal, but only if some of you recommend that to me.

Did I mention that this is really starting to frustrate me? This is a premium product, it should NOT have this kind of problems. I've sold my G29 because I thought I have something better, turns out I can't play at all now. Well thanks for that, Fanatec.


  • Joseph GossenJoseph Gossen Member, Moderator

    You should re calibrate your "Max/Min" points with the Fanatec Driver. This should resolve the issue, otherwise you could have a bad hall sensor. You can contact Fanatec support for a replacement. Simple swap out.

    How did you clean the hall sensor? Hopefully with compressed air only.

  • Okay, now I've seen in a video how the min/max is being set, but weirdly, I don't have those buttons on my Fanatec Wheel Properties page.

    I don't understand this. It feels like Fanatec is trying to push me into buying the new pedals. But after this experience, I will probably switch to another brand.

    By the way, I am not touching the throttle on the screenshot. It sometimes just goes like that. Yeah, probably the sensor is gone. I will try to switch the sensors from clutch and accelerator to see if it fixes that. But it probably won't, since I can't calibrate them. This is just total BS.

  • Next to the function test tab there is a settings tab, click on it and tick where it says manual calibration, go back to the function test and you have max and min for manual calibration;)

  • Sounded too good to be true...

  • Strange, maybe it is not possible with V2 pedals

Sign In or Register to comment.