Symptom: Fanatec Driver does not install/uninstall correctly

In some cases, your existing Fanatec driver may not correctly uninstall or become unusable as a result of a system change or Windows update.

If the standard uninstall procedure is not working, there are two steps that should help: Resetting your game controller to default, and/or manually uninstalling the device in Device Manager.

How to reset your game controller to default:

1) Connect your Fanatec device to your PC and turn it on. Then open the Windows Control Panel:

2) Select 'Uninstall a program':

3) Select 'FANATEC driver package' and click 'Uninstall':

4) After uninstalling the driver, return to the Control Panel and select 'View devices and printers':

5) Right-click the Fanatec device and select 'Game controller settings':

6) Depending on your product, there could be two devices listed. If this is the case, execute this step for both devices. Select the device and click on 'Properties'. Then switch to the 'Settings' tab and click 'Reset to default'. Then close the window by clicking 'OK':

7) Now reinstall the Fanatec driver package and reboot your PC:

How to manually uninstall Fanatec devices in Device Manager:

1) Disconnect all Fanatec devices from your PC and open Device Manager.

(Device Manager can be found via Control Panel\All Control Panel Items\Device Manager, or by simply searching for 'Device Manager' in the Start Menu):

2) View hidden devices and sort devices by container:

3) Then uninstall all Fanatec devices:

4) Reinstall the Fanatec driver package and reboot your PC:


  • This is the result what I always get, no matter what... Tried it all..... Guess mine is just bricked

  • I have exactly the same problem: (Win10, DD2, Porsche 918 rim with the METAL QR!)

    I cannot install a new driver because the old one (...381.msi) cannot be removed. I already did EVERYTHINg written here including the manual deletetion process. Also deleting the Fanatec driver package from Win uninstall created the same problem. I don´t know what more to do and am despearate. Searche for the 381.msi manually but cannot find it.

    I will also try writing a ticket, but maybe you can help me here.

    Root cause: I migrated to Win 11 and my "old" driver did not work anymore. When I installed the latest driver package (415) I detected that my wheel base only shows low torque (saying that the plastic QR is installed, which is not true). If I had know that was a known bug, I had not done it. So I migrated back to an older driver version and managed to find the one version that makes the DD2 fan stay on 100% ventilation all the time.

    So, 3 pieces of Fanatec softare = 3x fail!!!

    Imagine, then i migrated BACK TO WIN 10!!! And this is where I am; after the cleanup procedure here, no Fana software is working anymore. I cannot upgrade, cannot downgrade, manual cleaning failed.


    Please help me.

  • Add on: I tried this ALL 10x. It does not work. System cannot re-install because the old version cannot be found AFTER the above procedure.

  • Issue SOLVED!

    How: Fanatec support sent me this link:

    I downloaded the MS file and was looking for "Fanatec Drivers Package" and clicked on uninstall. That took a while, so I think the software was really screening through all registries etc...and in the end all left-overs were successfully removed. After this I could install the latest driver without issue.

    This is a must-have tool (once needed).

    Great stuff! Thank you.

    P.S. I migrated to driver version 423 which flashed the 687 FW to my DD2 and it STILL is not back to ho torque. Is this still bugged? To what version shall I move to (and how...)

  • My new CSL DD (which I waited for two months) arrived in a bricked state, does not even change its modes and completely unresponsive, is not recognized by any PC. Yet Fanatec support sends this link to me without even fully reading my ticket. How will that solve anything when the base is not recognized at all?

    And when I check these forums there are lots of people in this same situation. That weird Connect device failed error message, where you cannot proceed with an update or cannot roll back.

    Is it too much to ask for product that I paid for and waited since November to work?

  • I have this problem and tried several ways to solve it. Both the Fanatec solutions when it puts firmware 0, or trying to reload previous drivers, I can't update... The fan turns at maximum power but it never updates if the rest does. I sent a ticket to fanatec, but they don't give me a confirmation response as the e-mail has arrived or anything. I have the dd1 base under warranty. Can you tell me how long it takes to answer? Do you recommend that I resubmit a ticket? even though it says don't do it if there is already one sent.

Sign In or Register to comment.