Fanatec Shifter SQ1.5 - my solution for the misshift problem

Hi guys,

I upgrade my simrig from an G27 to an CSR elite ( i know, its old ^^ ) - so I was in need of an shifter and pedals.

Then I bought the V3 and the SQ1,5 shifter from Fanatec new.

I use an Omega GT RS6 simrig - which was nice for my G27 - but comes to its limit with the Fanatec hardware.

Since I couldnt find my mounting plate for the shifter, I screwed the shifter to a wooden plate and clamped this set to my sim rig. This "test" worked with the G27 shifter, but not with the Fanatec Shifter. As soon as I wiggled the mounted shifter, misshifts happened like R instead of 5th gear, but especially 2, 4 and 6. Especially when your shifter was in 4th and you wiggled the shifter, it showed like gear 2 or 6 is in ( for a ms ).

Long story short, I made another mounting bracket, this time i welded a metal one. Even this was made just for testing and isnt by far perfect ( only a 2mm base plate ), there is NO MISSHIFT anymore!!!

Even when I tried to wiggle the whole mounted shifter heavy, no more misshift.

So one solution for fixing the problem:

Make sure, the shifter is mounted properly to a simrig or table!!!!

( if this doesnt help, there is a nice video on YT from a guy who solved his problem by using an electronic tape around the hall sensor ! )


some "eyecandy" 😁 ( at the first picture bottom right, you can see my "wooden construction", the metal one is test project 2 )

Happy racing everyone!


  • Glad it worked for you...Mine has been firmly bolted to my steel rig the entire time (over a year now) and still misses shifts. I've done every fix for it I could find (including grounding the rig like Fanatec recommends and the tape fix) and still get errors.

  • I'm sorry but this does not work for me. I've been aggravated with this problem for years on three different Fanatec H-Shifters plus one replacement parts/shifter not to mention it happens on three different gaming PCs and two Xbox Ones (so it's the Fanatec shifter that is the problem). It is a race killer and kills other peoples race in the process when you miss the shift on a restart going from 2nd to 3rd, it jumps to 1st. You wreck, you wreck people around you and your engine is damaged. I can't even explain how pissed off that I am about this problem no solution. I have spent around $700 on three shifters and replacement parts to repair this problem. For a long time now I have been using the sequential side of these shifters. I paid for an H-shifter that I can't even use. I have been silent about it thinking there would be a fix but there needs to be some research done by Fanatec on this issue and give us a solution. I've spent over $7000 with Fanatec since 2009 and they have great products (the best for the money). These shifters cannot be trusted any longer,

  • Mine was misshifting constantly until I did this and now its flawless, I cant even get it to mess up if I try to mess it up.

  • edited December 2020

    Ok, little update again from my side.

    I moved my simrig in the room and suddenly, I had the same problems as some of you guys have: the shifter is rapidly shifting from like 1-3 and so on. Calibration did not help so far. I used the "poor man´s fix" and bumped gently on the shifter - off course no change at all.

    But then I gently, and I mean GENTLY pulled a tiny bit on the data cabel which is connected to the shifter and hey, that rapid blinking in the fanatec controller app stopped. But it still wasnt perfect. Ok, what can I try else? I moved the bottom lever for locking to sequential shifting forward and backwards and man, now everything works perfect for over a month again.

    I mean I raced many laps changing from H shifter to sequential shifter, no problem anymore.


    • mount the shifter to a stiff plate / rig
    • try gently pulling/pushing the data cabel, moving the H- / sequ shifter lever
    • electrical duct tape mod ( on youtube - I did not open my shifter because of warranty )

    ( everything at your own risk, its just my experience what worked for me )

Sign In or Register to comment.