Clubsport shifter wont calibrate. Stuck in 5 and 6

I cannot calibrate the Clubsport shifter.

  1. It is connected via rj12 to dd2 base- Not usb adapter
  2. I lost usb adapter and have new one on the way
  3. I have updated all firmware, software and drivers to current
  4. i tried calibrating thru the wheel direct and thru Fanatec properties. Same result, shift into 1 and registers as 5. Shift into 2 and registers as 6. Shift into 3 and registers 5 etc.
  5. I have switched rj12 cables with same result.
  6. When putting into sequential, similar. stuck in down shift position even though it is in neutral.

Any ideas?


  • There is a hall effekt sensor that registers your left/right position. It sounds like this could be stuck in the right position for some reason. Since it is magnetic, the problem could be one of many. Take a look at The Sim Racing garage’s review of the shifter on youtube if you want to look inside without disassemblying it. I am not an expert, so never trust me on anything tecnical. ;-)

  • The problem may be easily solved by placing some double-sided tape between the plate (the one with a double connection) and the metal part. I was failing and I didn't recognize gears 1, 3 and 5 and I'd get my reverse engaged until I separated the plate using double-sided tape. From then on it works perfectly. I hope it helps. Best regards!

Sign In or Register to comment.