Clubsport Shifter Will NOT Work, Help!

Randy FlowersRandy Flowers Member
edited February 2021 in Fanatec Other

I cannot get my Fanatec Clubsport SQ (H pattern shifter) to work.

I using Assetto Corsa.

My setup is the following:

Accuforce V2 wheel, HE Sprint pedals, Fanatec Clubsport H pattern shifter

I have the Fanatec shifter plugged in via the RJ12 cable direct to the USB adaptor that i got from Fanatec, and the USB adaptor is plugged into a USB port

Note that i have checked and the slider on the shifter is set to 8 (H pattern), not to sequential mode.

I have setup the Fanatec driver for 64 bit (multiple times). Here are the Fanatec driver setup notes:

1) Inside the driver setup it sees 'Fanatec Clubsport USB adaptor (shifter mode) and i choose that for the 'preferred device', 2) If i click on 'Fanatec Clubsport USB adaptor (shifter mode) and choose 'properties', then do a firmware update, and it updates fine, 3) Then, i choose 'calibrate shifter' and calibration seems to work fine. it says 'DONE!'

Then, i go into the Assetto Corsa settings to setup the shifter.

I go into 'Controls' then 'Shifters', and then check the 'Use separate shifter'. Below that it shows 7 gears and reverse. I choose gear 1 and it says 'waiting for input' but it immediately assigns it to 'button 1' or 'button 4' despite me not having put it into first gear yet or done anything else yet. I put the gearshift into first gear and nothing happens, it just stays as button 1 or button 4. If i choose 'clear' and clear out button 1 or button 4, and put the shifter into first gear before clicking on the 'click to assign' field in assetto corsa, it puts in either button 1 or button 4 again. Plus, they are all flashing, along with detected devices screen to the lower left in the video, which also flashes back and forth between gear 1 and 4. 

At other times, if i have just plugged the USB out and then back in to see if that helps, if i click on the 'waiting for input' and put and then put it into first gear, it doesn't do anything (it doesn't see that it is in gear 1, doesn't seem to see the shifter).

I have also disabled the 'automatic throttle blip' and 'automatic clutch' in the car realism settings, but it still doesn't see the shifter.

I have tried this with 2 different computers (just got a new computer, so tried it on the old one and the new one, same issue), and have tried it in multiple different USB ports

I have used the 'configuration wizard' in AC, and when i get to the H-pattern setup, it tells me to 'engage third gear', i do that and the screen doesn't change at all, so nothing happens. Then, i can't go further in the configuration wizard

Note that Assetto Corsa is the one sim racing game i have played, but i decided to see if it would work with rFactor2, so i loaded that also and, when i try to assign gear 1, gear 2, etc, nothing happens in that game either, it also does not see the gears.

What am i missing?

Also, i tried to start a formal technical help ticket with Fanatec, and just spent over and hour and it keeps telling me to fill in the 'Comment' part of the form, even though it IS filled out. When i hit submit after putting in the capcha thing, it won't let me submit and the Comment part of the form goes red and clears out my comments. The form will not allow me to submit, SUPER frustrating. Note that i tried to submit both in Mozilla and Microsoft Edge, so it is not due to the browser i am using. How do i open an actual tech support ticket.

Also, what are the exact hours and phone number to contact Fanatec customer service? Do i have to call overseas? I live in the USA. How exactly do i call Fanatec?


Randy Flowers


  • I just don't get it. You said "Then, i choose 'calibrate shifter' and calibration seems to work fine. it says 'DONE!'" It was like you put first gear and press done, after the second and so on. Or it just said ,DONE, without this steps for every gear?

  • I would try just using one connection at a time. It seems you’re trying to connect using 2 connections. Try the USB only.

  • You said 'I would try just using one connection at a time. It seems you’re trying to connect using 2 connections. Try the USB only.'

    Not sure what you mean. I am only connected to the computer with the Fanatec shifter using a single RJ12 line into the Fanatec USB adaptor and then the adaptor plugs into a single USB port.


  • No, when i used the Fanatec firmware setup steps, i simply did what it told me to do. It said to put it into 1st gear and click next, so i did, put it into 2nd gear and click next, did that and did that for all gears plus reverse, and when i was done, it said 'DONE!' so it sure seemed to calibrate correctly in the Fanatec firmware configuration.

    However, when i get into the game itself (Assetto Corsa), it will NOT see the shifter when i shift into gear during setup. 

    Just did it again, and here are the exact steps in trying to get it to setup the shifter in Assetto Corsa:

    Click the 'Use H Shifter' box (in Assetto Corsa)

    Click the 'Click to assign' field for gear 1

    It immediately assigns 'Button 4' when i click the 'Click to assign' field. If i put the shifter actually into first gear, nothing happens at all, still says 'Button 4' in the gear 1 'click to assign' field. If i mouse click into the gear 1 click to assign field again, it will change back and forth from 'Button 4' to 'Button 1'. It only assigns either 'button 1' or 'button 4' when i click in the click to assign field, and doesn't seem to do anything at all when i shift into any gear on the shifter itself.

    It will NOT assign the gears to the shifter gears in Assetto Corsa!  As i said, it DID seem to assign the gears correctly when i calibrated the shifter in the Fanatec firmware setup.

    It seems like it thinks it is in sequential mode with only 2 gears (button 1 and button 4 in its mind i guess), but i do have it set to H pattern on the shifter itself.

    Note also that it DOES ACTUALLY SEE the shifter device. In the shifter device, it says 'Fanatec Clubsport Adaptor (Shifter mode).'

    If i can't figure this out, i am sending damn thing back and getting a Thrustmaster shifter.  I would love to use this shifter though, as it is supposed to be the best one. Help please! I have heard of customer service horror stories about Fanatac, and this was the only piece of hardware i bought from them, and here i am with it not working, and can't get any help from Fanatec customer service.

    Please help!

    Randy Flowers

  • edited February 2021

    Can you check if after calibration its show correctly in the fanatec driver for every gear?

  • edited February 2021

Sign In or Register to comment.