FanaLab 1.57.4 Download (Previously 1.57.2) - Post your Feedback here



  • Tuning Menu working fine again for me - thanks for the quick fix and have a nice weekend :)

  • Next working means? Is it coming soon or is it fixed already? I still can´t open Fanalab. All is done. It is only shown a short Fanatec Logo after that will happen nothing.

    CSL DD

    Windows 10

    all Driver and Frimware updates done, always rebooted and so on and so on...

    Also the the folder in Appdata deleted.

  • Check the Windows Eventlog please. Seems more like an issue there

    Search for Event Viewer -> Windows Logs -> Application -> search there for an Error with Fanalab

  • Marcel PfisterMarcel Pfister Member, Administrator

    Thanks, we'll take a look and should be able to fix this next week.

  • Marcel PfisterMarcel Pfister Member, Administrator

    Like Matthias suggested above, the event logs would be really helpful to see what is happening in the moment of the crash.

    In addition you can also provide the FanaLab log files from: C:\Users\Public\FanaLab Logs

    Regarding "next working on" means what our developer tries to fix next.

  • Marcel PfisterMarcel Pfister Member, Administrator

    The issue of not showing base or wheel is now fixed for the CSL Bases in the version 1.57.3 I've uploaded.

    We've decided it would be quicker to just fix it and not re-write a whole new software, hope that's fine.

  • No this did not work I deleted folder and even reinstalled still not work. V 1.53 works no problem.

  • Yeah exactly. Kernelbase is system core normally. I would say that the problem is in windows itself. Let me tell you a few cmd commands you can try when I’m home in about an hour

  • try to run cmd as administrator and then this command: sfc/scannow

    (SFC-System File Checker)

  • Fanalab crashes on launch, never opens

    Using CSL DD with all the firmware that came with driver 410, also running CSP v3, and Shifter V1.5 plugged into the base and 918 RSR rim. Wheel works fine in game, but fanalab just opens the splash screen then dies. Tried reinstalling and updating fanalab, tried uninstalling fanalab and the driver, then reinstalling the driver rebooting and installing fanalab. The issue persists.

  • FanaLab_x86_v1.57.3 does not launch with 410 driver.

    Faulting application name: FanaLab.exe, version:, time stamp: 0x611f7e90

    Faulting module name: KERNELBASE.dll, version: 10.0.19041.1151, time stamp: 0x5da51925

    Exception code: 0xe0434352

    Fault offset: 0x0012b512

    Faulting process id: 0x34b4

    Faulting application start time: 0x01d7961230fd14ac

    Faulting application path: C:\Program Files (x86)\Fanatec\FanaLab\Control\FanaLab.exe

    Faulting module path: C:\Windows\System32\KERNELBASE.dll

    Report Id: 3276f97d-1b29-4cdf-b89f-476bb322b195

    Faulting package full name: 

    Faulting package-relative application ID: 

    Application: FanaLab.exe

    Framework Version: v4.0.30319

    Description: The process was terminated due to an unhandled exception.

    Exception Info: System.FormatException

      at System.Number.StringToNumber(System.String, System.Globalization.NumberStyles, NumberBuffer ByRef, System.Globalization.NumberFormatInfo, Boolean)

      at System.Number.ParseDecimal(System.String, System.Globalization.NumberStyles, System.Globalization.NumberFormatInfo)

      at System.Convert.ToDecimal(System.String, System.IFormatProvider)

      at ProfileUpdater.PWSProfile.Update(System.String, System.String, System.String)

      at ProfileUpdater.PWSProfile.Update(System.String, System.String, System.String)

      at PodiumControl.PCUiUserControlTabSaveLoad.set_SettingsListSelectedItem(SettingListItem)

      at PodiumControl.PCUiUserControlTabSaveLoad.FileWheelSettingsBuild(System.String)

      at PodiumControl.PCUiUserControlTabSaveLoad.set_GameListSelectedItem(GameListItem)

      at PodiumControl.PCUiUserControlListboxGames.PrivateGameListboxBuild(Boolean, Boolean)

      at PodiumControl.PCUiUserControlListboxGames..ctor()

      at PodiumControl.PCUiUserControlListboxGames..cctor()

    Exception Info: System.TypeInitializationException

      at PodiumControl.PCThreadGameTelemetry..ctor()

      at PodiumControl.WindowMain..ctor()

    Exception Info: System.Windows.Markup.XamlParseException

      at System.Windows.Markup.WpfXamlLoader.Load(System.Xaml.XamlReader, System.Xaml.IXamlObjectWriterFactory, Boolean, System.Object, System.Xaml.XamlObjectWriterSettings, System.Uri)

      at System.Windows.Markup.WpfXamlLoader.LoadBaml(System.Xaml.XamlReader, Boolean, System.Object, System.Xaml.Permissions.XamlAccessLevel, System.Uri)

      at System.Windows.Markup.XamlReader.LoadBaml(System.IO.Stream, System.Windows.Markup.ParserContext, System.Object, Boolean)

      at System.Windows.Application.LoadBamlStreamWithSyncInfo(System.IO.Stream, System.Windows.Markup.ParserContext)

      at System.Windows.Application.LoadComponent(System.Uri, Boolean)

      at System.Windows.Application.DoStartup()

      at System.Windows.Application.<.ctor>b__1_0(System.Object)

      at System.Windows.Threading.ExceptionWrapper.InternalRealCall(System.Delegate, System.Object, Int32)

      at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(System.Object, System.Delegate, System.Object, Int32, System.Delegate)

      at System.Windows.Threading.DispatcherOperation.InvokeImpl()

      at System.Windows.Threading.DispatcherOperation.InvokeInSecurityContext(System.Object)

      at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)

      at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)

      at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object)

      at MS.Internal.CulturePreservingExecutionContext.Run(MS.Internal.CulturePreservingExecutionContext, System.Threading.ContextCallback, System.Object)

      at System.Windows.Threading.DispatcherOperation.Invoke()

      at System.Windows.Threading.Dispatcher.ProcessQueue()

      at System.Windows.Threading.Dispatcher.WndProcHook(IntPtr, Int32, IntPtr, IntPtr, Boolean ByRef)

      at MS.Win32.HwndWrapper.WndProc(IntPtr, Int32, IntPtr, IntPtr, Boolean ByRef)

      at MS.Win32.HwndSubclass.DispatcherCallbackOperation(System.Object)

      at System.Windows.Threading.ExceptionWrapper.InternalRealCall(System.Delegate, System.Object, Int32)

      at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(System.Object, System.Delegate, System.Object, Int32, System.Delegate)

      at System.Windows.Threading.Dispatcher.LegacyInvokeImpl(System.Windows.Threading.DispatcherPriority, System.TimeSpan, System.Delegate, System.Object, Int32)

      at MS.Win32.HwndSubclass.SubclassWndProc(IntPtr, Int32, IntPtr, IntPtr)

      at MS.Win32.UnsafeNativeMethods.DispatchMessage(System.Windows.Interop.MSG ByRef)

      at System.Windows.Threading.Dispatcher.PushFrameImpl(System.Windows.Threading.DispatcherFrame)

      at System.Windows.Threading.Dispatcher.PushFrame(System.Windows.Threading.DispatcherFrame)

      at System.Windows.Application.RunDispatcher(System.Object)

      at System.Windows.Application.RunInternal(System.Windows.Window)

      at System.Windows.Application.Run(System.Windows.Window)

      at PodiumControl.App.Main()

    Uninstalled and reinstalled FanaLab_v1-53 - downloaded on 07-29 don't know where I got it but it works.

    So painful and easily avoided. Finding and wading through all this has been the entire opposite of positive.

  • Try what I said already and install actual visual c redistributable

  • That didn't work. 53 works fine, but obviously doesn't support the CSL DD. But had no issues with CSW 2.5

  • It seems in RaceRoom the vibration of my Formula V2 Wheel on a DD1 Base is not working if the traction control is active.

    The vibration motor works with the rev limiter very well in RaceRoom and the LEDs on the wheel are working if the traction control is active. 

  • The Tuning Menu works again with my DD1/PS4.

    Thanks/Schönes Wochenende :-)

  • base dd1 ps4 tuning menu visible again ... thanks

  • Thanks, I did that and it didn't work. I uninstalled and downloaded 1.57.3 and still the same issue. Made sure there was no PodiumControl folder. Any other ideas?

    Thanks very much for the help.

  • This always solved this issue in the past... You'll have to wait for Maurice or Marcel to help you, I'm not home...

  • Question, I use Maurice's profiles to get the right LED rpm's etc on my CSv2 formula and since the new ones I can't get them matching the cars anymore? Just get the same for everything.

  • in fanalab v 1.57.3, i am not able to select a function for the podium button module endurance for the ITM. it only allows selction for the wheel base.

  • edited August 2021

    That's the case for 2 years. Auto-page-switch and Screen selection for BME NEVER worked yet.

    Coming soon.

  • Coming soon™ 🤣

  • edited August 2021

    Downloaded the latest version yesterday, and it worked fine yesterday evening. Just now opened it, tried to delete and old pws file for wheel settings and program crashed, and wont open again.

    I've removed the app and reinstalled, but the only thing that happens is the app starts up, get the Fanalab start screen opening, and then it completely shuts down before the main program has opened. Restarted PC numerous times, but nothing. New app doesn't want to open and run.

    I remove v1- 57,3 and install V1-54-5 and it works perfectly. Then try update to newest version again, and exact same problem.

    Any ideas...

  • Solved Fanalabs not opening...

  • Jack WallaceJack Wallace Member
    edited August 2021

    CSL Elite PS4 w/ latest firmware and Fanalabs version - can't do anything in the tuning menu (clicking the little up chevron does nothing):

    [Edit] Completely uninstalling Fanalab and nuking the AppData and Program Files folder before reinstalling it fixed w/e issue I was having.

  • edited August 2021

    Hello, after installing latest Fanatec drivers and latest Fanalab version, I´m experiencing some User Interfase glitches when mouse pointer is over the app or when turning the wheel: the labels are disappearing, some icons change size or get pixelated, the sliders in tunning menu get bigger/pixalated.

    This happens every time I open the new Fanatec Control Panel or when using Fanalab.

    I´m runnign Win10 with the latest updates, latest NVidia drivers.

    Please see following videos for a better understanding:

    I´ve already tried:

    • Fresh install of Drivers and Fanalab (deleting the AppData / Program Files / My Docs realted folders)
    • Disabling Ndivia Surround


    • Fanatec Podium DD1
    • PC Win 10 ver. 21H1
    • Intel(R) Core(TM) i7-9700KF CPU @ 3.60GHz / 16Gb RAM
    • Graphic card: Nvidia geforce RTX2080, driver 471.68
  • after the update, fanalab won't start.

    I've uninstalled, resintalled, started as admin and nothing. it just shows the splashscreen and then nothing happens.

    hardware: CSL DD Boost kit, ClubSport Steering Wheel Formula V2 and Podium Advanced Paddle Module.

  • Same problem, fanalab does no start after splashscreen. I've uninstalled and reinstalled, I also deleted the Podium folder in Appdata and it does not work...

    I have Podium DD1, McLaren GT3 V2 wheel, 410 driver, windows 10... Everything updated and everything works except fanalab. I think a new hotfix is needed...

This discussion has been closed.