Can't assign wheel or pedals

I have f1 2021 installed on my PC via Steam. I have a CSL Elite base, pedals with Clubsport Formula V2 wheel.

On Fanalab F1 2021 isn't showing at all - not sure if this is a problem or not? Assetto Corsa and Assetto Corsa Competizione are showing and are both working fine.

F1 2021 launches fine but the Fanantec controls are all wrong - throttle fixed at 50% and pedal inactive, brake inactive, clutch operated throttle and most steering functions are wrong. If I try to reassign the controls within the game it is not picking up most inputs.

All my drivers are current and I have the latest version of Fanalab. As I said, all other games are working fine with the Fanatec gear. I'm new to all this...Is there something I'm missing??


  • I have the same problem with the new CSL DD and formula V2.5 wheel and new CSL Pedals! As for now, i use my CSL DD in compatibility mode and it works fine but i'd like to enjoy with my CSL DD and not having issues

  • edited August 2021

    Defo would like an update to this soon, i Have CSL elite pedals, Formula V2 wheel and CSL DD base. Pedals wont even recognise on Fanalab and F1 2021 has all sorts of wierd bug like the throttle and brake being stuck at 50%. Also was getting no force feedback.

  • I also have issues with the CSL Elite pedals and the CSL DD base with F1 2020 limited edition wheel. Throttle is by default at 100% and when pressed it goes to 0% (Inverted) but the clutch and brake are not inverted.

    Have not tried the legacy mode yet.

  • I’ve A LOT of issues with the new CSL DD and the F1 2021 LE steering wheel + podium advanced paddles too!!!

    in pc mode steering is not working, the game doens’t recognize the wheel and wheel base, just some buttons works, I tried everything but nothing worked.

    in compatibility mode some important buttons are not mappable or do not work at all… result is that the game is unplayable and I will be forced to roll back to my logitech G29… ridiculous!

    same things on F1 2020…

    I so frustrated…

  • almost everithing got fixed reinstalling devices firmwares.. stil the two buttons designated to fast forward and fast backward are not respondign when activating flahbacks in game, but I can work around it...

Sign In or Register to comment.