Fanatec Driver installation Windows 10 ARM

Had some issues with my LC's calibration so I had to get Fanatec Driver to recalibrate, I'm running a M1 Pro Macbook with Parallels and Windows 10 ARM (21H1). I can't get the Driver to install properly, keep getting the error message "There is a problem with this Windows Installer package." (Screenshot below).

Tried several versions, 423, 410, 402, no dice. Fanalab installs w/o issues. Tried with and w/o wheel plugged in, can't seem to get it through. Had to revert to my Mid 2012 MBP and Parallels with normal 64-bit Win10, where it installed first try, unless its a problem with just this Virtual Machine, Parallels should work. So my question, will this work on an ARM Windows? It should run it fine with its own emulation, anyone have any experience with this?


  • I would love to know if there is a answer to this also? Im trying to do the same.

  • edited November 2021

    +1 I was having the same issues running parallels windows 11 arm, and I got the same error in crossover too. However, in crossover, I was able to get it to run by using a 32 bit bottle... the only problem being that I couldn't get any of my games to run in this 32 bit bottle.

  • Same problem here. I recently replaced an Intel-based Mac with Bootcamp, but now must run Parallels with Windows 11 ARM. Is there a solution for us?

  • Same issue here. Hope someone has resolution soon for us to try. Thanks.

  • Same problem and still no answer...

    Please Fanatec, we are so many players with the issue and we need a solution.

  • edited December 2021

    +1 - also having the same issue. Would be perfect to have a solution to fix that issue. Thanks in advance.

  • Rob FordRob Ford Member
    edited January 2022

    +1 I have the same issue. No physical PCs in the house so virtualisation is my only option for updates. Any news or workarounds been found?

  • Question: do you know if it’s possible run fanatec driver using a microsoft surface pro x (arm processor)?

    fanatec says:

    Unfortunately we haven't tested it yet and we can't confirm if this is working. 

    If you want to test it, you can do it, please make sure you have one of Windows 10 or 11, because then I think it should not be a problem. 

    But please note as we cannot confirm if this is working, you go to test it on your own risk. 

    If you test it, please let me know the result.

  • Danny MøllerDanny Møller Member
    edited February 2022

    +1 Same problem here! Super frustrating! Getting ready to dip my toes in the sim-racing pool in a weeks time and this is holding me back! :(

    EDIT: Also got it to work using Crossover with a 32-bit bottle. But can't run Fanalab in that enviroment.

    Speaking of Fanalab. I had no problems installing that on my M1 Mac (using Parallels), but obviously can't run it, because it requires the Fanatec driver installed.

  • Just a quick update. Couldn’t use Crossover after all. I couldn’t connect any USB peripherals using Crossover. Ended up buying a cheap used Windows laptop to use solely for updating and tweaking my Fanatec gear. What a shame! :(

  • Michael VoitzMichael Voitz Member
    edited March 2022

    All, I have not checked if an ARM version is working or not.... So I have bought the latest Parallels with Windows 11 Home and get the same Error Message as shown above! Is there any update or maybe a BETA I can use?

  • Same here, the exact same situation. I’m no longer able to update the firmware of my Fanatec devices using Parallels since I migrated to a M1 machine. :( I’ll keep an eye on this thread.

  • Having the same issue / message when attempting to download the driver running Parallels with Windows 11 on my M1 Macbook Pro. Hope Fanatec can provide some guidance on this issue soon.

  • Hello

    I have the same problem, even with the 440 beta driver on Windows 11 Pro, running on Parallels, which is running on a MacBook Pro with an M1 chip.

  • Same Issue, ended up use my work Windows laptop to do the Job.

    Any update would be appreciated.


  • Is there any update here? I am running into the same issue. Running a M1 mac with Parallels, windows 11 64 bit. Pretty disappointing!

  • Alright, no real updates here unfortunately.

    Just installed a new version of Windows 11, 22H2, build 22621.525 on Parallels VM.

    Tried installing driver 447, same exact issue as my original post.

  • Tried installing driver 454 on my 16" Macbook M1 Pro running parallels pro, and it's not working either. This is very unfortunate and I hope it gets addressed, however, I fail to see it will.

Sign In or Register to comment.