Firmware update ClubSport Pedals V3 inverted

Hi Fanatec,

I have just received my new fanatec setup, DD1, F1 wheel, ClubSport Pedals V3 inverted.

I downloaded the latest driver package, 429. This installs the 'Fanatec Control Panel'. Here we can update firmware of the attached devices. Almost everything updated fine... just not the pedals.

I have the pedals connected directly to my PC but the 'Fanatec Firmware manager' won't let me update the pedals. The only message I get from your software is: '[ClubSport Pedals V3 and CSL Elite Pedals LC can only be updated when connected to the PC directly via USB]'. Like I said before.... the pedals ARE connected to my PC directly via USB.

Is this a known issue? Will you be fixing this? Is the controller on my ClubSport Pedals V3 broken? I'd like to know from you.

I have tried grabbing another driver (402) directly from this page: ClubSport Pedals V3 inverted | Fanatec But, when I unzip the file and try to run the x64 package I get an error message from the Fanatec software: 'You have already installed a newer driver package'

Thanks in advance for your help.


  • You dont have them also connected via RJ12 to the base by any Chance?!

  • They are. But I also tried without the RJ12 attached to the base. But then the 'Fanatec Control Panel' doesn't recognize anything attached. The 'Fanatec Control Panel' software only recognizes the pedals if the base is attached to the PC as well.

  • edited November 2021

    They are?

    Well.. Then you most likely bricked your pedals.

    NEVER EVER connect then both via USB and RJ12 at the same time!!! This will damaged the PCBA of the pedals which is not covered by warranty.

    For pedal update they have to be connected via USB ONLY.

    You can try newest driver 431 but if it's still fails well then they are broken.

    But that's not bad because the newest firmware 1.32 for them is not good anyway and the good old 1.30 is still the best firmware.

  • As I'm thinking about your comment and my reaction on that again... it makes sense to me that my PC is not recognizing the pedals if they are connected solely, there is no power brick attached to the pedals. The power brick goes into the DD1.

  • edited November 2021

    The pedals dont need power. They are powered by USB when connected via USB - thats enough.

    When connected to Base they get power through that. But as said, do NEVER connect them both at the same time.

  • They are not bricked. They work when testing in 'Fanatec Control Panel' and when racing. The problem I have is that I can't update the firmware of the pedals.

    I'll give it some more tries and wait for an official Fanatec rep to reply. Otherwise I'll rma the products. Thanks for your replies Maurice.

  • I'm having a similar problem with my V3 pedals. When I try to update them to V1.32 it just doesn't work.

    Can anybody help me out please? I really don't fancy trying to do it manually in case I brick them.

    I'm on 1.31 right now.

  • That's what I'm getting but it's just not happening.

  • Hi,

    I've got the exact same issue with my brand new pedals v3.

    They are currently on v1.30 version. At first the system tells me that the v1.32 is available, it tries to make the update, then tells me that the update is done before to show that the pedals are now disconnected.

    When I connect them again, the firware is still the v1.30.

    Any update on this issue please ??

    (Here are the steps in screenshots)

  • Did you tried to do a manual Firmware update instead of the automatic one?

  • I've got the exact same problem. It says it is done, pedals disconnect, reconnect and still on 1.30. Pedals are all detected fine and work as expected but can't update to this latest firmware

  • edited April 2022

    Did you tried to do a manual Firmware update instead of the automatic one?

    But anyway, 1.30 is the better firmware so be lucky to not be able to update....😅

  • "Did you tried to do a manual Firmware update instead of the automatic one?

    But anyway, 1.30 is the better firmware so be lucky to not be able to update....😅"

    I did but doing a manual update didn't give me any extra options. It just does the same thing. I click the manual update button then they disconnect. Someone mentioned there should be 3 ... to select the firmware version but I don't get that.

    To be honest I don't have any major reason to want to update it, but its just annoying that its not doing what it should and there doesn't really seem to be a good way around it

  • In case anyone finds this forum I found a solution. I tried downloading a slightly older driver package, in this case I think it was version 410. When I installed this the actual firmware window now appeared and it flashed it correctly. It still updated to version 1.32.

    Not sure if the problem is with the newer software version not bringing up the actual process that does the firmware update, or if I had a windows problem as I did also reinstall windows, but maybe give the older driver package a go. To download you need to go the forum page linked off the driver and scroll to the version you want to download.

    Hope it helps at least in the short term

  • What a pain. I'm on my 3rd set of various CSPs over the years and have yet to update any.

    Having to connect straight to the PC to update is a horrible way to do it, IMO. After the pedals have been mounted, getting to the input is a major pain. So much so that I'd guess hardly anyone messes with it.

    I find it hard to believe they can't find a solution to update these through the Base.

  • It's technically impossible to update anything via a RJ12 Port.

  • nin channin chan Member
    edited June 2022

    Hi guys,

    I got the same problem here, the pedal stucks in v1.30 and unable to update, but finally got it fixed.

    When trying to launch "fwpedalupdater.exe" in the folder fanatec/fw/ manually, it said missing vcruntime140.dll and msvcp140.dll. These two are Visual C++ files.

    Then I installed back Visual C++ Redistributables.

    Not sure which versions are a must since I had tried to install all x64 with no luck. Then i got the updater successfully ran after installing 2015-2022 x86. So, i guess probably "Visual Studio 2015, 2017, 2019, 2022" x86 version, maybe x64 necessary as well.

    If the updater successfully run, then just close it and update the firmware as usual with Fanatec Control Panel.

    Good luck mate. Hope it helps.

  • Thanks "nin chan" your suggestion worked!

    In Win10 64bit. Installed "Visual Studio 2015, 2017, 2019, 2022" x86 version"(link in nin chan's post above) and was able to update Clubsport V3 FW to 1.32 (my V3 from v1.30, purchased in July 2022).

    Prior to installing Visual Studio, Fanatec application would say FW updated but it never executed the actual FW update sequence.

    As a reminder again to all, don't connect both USB and RJ cable at same time. Only USB for FW update.

  • In the meantime, there is a newer firmware 1.35 available with driver 443 ;)

Sign In or Register to comment.