wrc10

Good aftenoon.

I have a problem with the game: wrc10. It doesn't recognize the Fanatec steering wheels. I don't have any problems with the base, but when I have to set up the steering wheel right or left it doesn't work.

I read that when I'm inside the game I have to remove the steering wheel and the put it back on but it still doesn't recognize it.

The only thing that recognizes the steering wheel is when I put the base in sleep mode, but then the base doesn't have any strength. I can drive but without sensing anything.

Greetings.

Comments

  • Hi,

    I have a similar issue….. just bought WRC 10 on the PS5 and although it recognizes the wheel and I can accelerate / brake , steer etc. There is no force feedback / resistance on the wheel. To the point where it is unplayable…. Played around with some settings with no luck. I guess as this is a game with the fanatec logos all over it ( in game ads , loading wheels) it is / will be supported at some point…

    All this using the GT DD pro wheel.

    ps: I have the same issue on Dirt 5 but not that fussed about it….. but not being able to play WRC somewhat sucks 😩 also , I have tried on WRC 9 too on the PS5 with the same issue…

    anyone with any ideas or possibly a solution ?

  • Following. I have the same issue George describes above with the GT DD Pro wheel on WRC 9 (PS4). In my case, the steering works only at certain points: When I brake and if I keep the revs low. If I get to a high speed, the steering craps out, and I need to brake to get the steering to work again. Really bizarre. Anyone with any ideas?

  • WRC 10 officialy supported by Fanatec ..... and now I am here and looking for suggested settings, no category for WRC .... no comment 😫

Sign In or Register to comment.