[Resolved] Clubsport V3 throttle doesn't get to 100% on a GT DD Pro.

edited March 2022 in Pedals

I'm dissapointed.

Although on PC says that throttle reachs 100%, on Gran Turismo (PS5) cars don't.

With CSL that came with DD Pro there is no problem. I realized that problem when I was doing missions, seemed IMPOSSIBLE without a working throttle.

When I start the mission, going with full pressed throttle (clearly not all power, but almost), if I press the controller its easy to see that the car gets a boost.

Since the web says "Compatible to any Fanatec Wheel Base or Fanatec Racing Wheel with RJ12 Pedals connector." this is really bad. I don't even know if this can be solved by software or if the pedal has a physical problem.

Can anyone help?


  • Hi Victor,

    If you have the ability to calibrate your system on a PC, you could try calibrating the throttle (always use manual calibration option in my opinion) to be at 100% when pedal travel is only at say 90%. Then see how the game works on your PS5 and if you make full output in-game.

    I've had many teething issues like this with Fanatec gear on new games, I suspect most development is put into Logitec or even Thrustmaster development, and although Fanatec is premium it gets less focus initially due to the smaller user-base. Forza is a perfect example where after Horizon 5 was release it took many months for fixes to trickle in for Fanatec problems (eg Handbrake not working at all), even Horizon 4 introduced a bug years after release (was some time in late 2020 from memory) where the throttle signal got garbled and didn't work at all. Generally it seems to be at the software developer (ie the game) end rather than Fanatec, if things look right in the calibration tool on PC. So you could also raise a support ticket for the game through the game developers website.

    Good luck,


  • Thanks for the reply.

    I calibrated the throttle in manual to be 100% when travel is at 90% and it keeps doing the same. Even put at 25% to verify that in GT7 reaches that "100%" on 25% travel, but is not the real 100% power, there is still lack of power.

    This is turning a 500€ headache. Painful.

    As you said the Fanatec problems with new games, this can't be allowed in GT7 since its "the official Direct Drive Wheel for Gran Turismo".

  • Really? I have ordered the same pedals just this week and this is unacceptable.

    Can anyone else confirm if it's a general thing?

    Could shortening the physical throttle travel fix the problem?

    Here is an example of how to adjust it:



    (Sorry for google translate)

    ¿En serio? He encargado los mismos pedales justo esta semana y esto es inaceptable.

    ¿Alguien más podría confirmar si es algo generalizado? 

    ¿Acortar el recorrido físico del acelerador podría solucionar el problema?

    Aquí hay un ejemplo de cómo ajustarlo:



  • Dominic BrennanDominic Brennan Member, Administrator

    It's not a general thing, we've tested the game extensively with all pedals. But we are investigating a few reports of unusual behaviour that is potentially related.

    [Fanatec Community Manager]

  • Thanks for the reply Dominic.

    I hope this kind of problem can be solved, please!


  • Ok, it was the usb cable from the pedals to the computer. Once I put another cable I was able to update the pedals firmware and now is all ok.

    Thank you all !

Sign In or Register to comment.