Podium Advanced Paddle Module - Problem

edited May 2020 in Fanatec Other


sorry for the double post ( in the beta driver section ) i think it is better to post it in this category here.

Yesterday i have received my fanatec hardware.

DD2, Podium Hub, BME, APM, Porsche 911 GT3 Rim, V3 Pedals.

I installed the latest ( at least i think these are the latest ) driver/firmware versions:

PC Driver: 365

Wheel Base: 672

Wheel Base Motor: 38

Steering Wheel: 11

Podium Hub: 2

My Problem: My APM works fine with all 3 paddles on the left side, while on the right side only the clutch is working. The middle and the upper paddle shifter dont work. I already took everything apart again to see if some cables are loose or something like that but there is nothing i would describe as loose or strange. both sides are connected to the Podium Hub correctly and in the APM itself, all cables seems fine. I mean, the left side is working just fine and on the right side only the bottom clutch works.

Does anybody know how that is possible or what i can do?

Thanks in advance.



  • Hi Marion,

    thanks for the reply.

    With APM firmware, you mean this one?

    But this driver package is way older then the 365 currently installed or do you mean something different?


  • The APM doesnt have a firmware, only Steering Wheels, the Podium Hub and the BME have firmwares.

    And he is already on the very latest driver and firmwares, nothing to update.

    This sounds to be a hardware issue which needs an RMA and you should contact the support.

  • edited May 2020

    Hi Maurice,

    thanks as well for your reply.

    tomorrow i will open the Podium Hub and Paddle Module again and double/triple check if there really is nothing i can see. Otherweise, RMA currently will probably take a while but i guess i will have no other choice then.

  • Went home to try the following: took everything apart and checked again, there is really nothing wrong with the cables or connector pins. Everything looks perfect. Then i connected the right Paddle Module to the left connector on the Podium Hub to see if its really the Paddle Module or the Podium Hub. It worked as it should. Connected the left Paddle Module to the right connector on the Podium Hub and again, just the clutch worked, the middle and top paddle again, no function.

    So its the right connector on the Podium Hub? There is really nothing different to the left one, everything looks the same but for some reason, the the right connector doesnt recognize the middle and top paddle.

    No i cannot use anything because without the manual shifting it makes no sense to race :/

  • Seems like you need to RMA it. That sucks

  • Hi Jeffrey,

    unfortunately yes. I opened a support ticket and hope for a fast response.

  • Hi

    i have the same problem.. none of the paddles working on right side ??

    was their a solution for this problem?

Sign In or Register to comment.