Omsi 2

Hello, I'm trying to get my new Gran Turismo DD Pro set up with the bus simulator OMSI 2. In the controls setup page of the game there are two entries for the Fanatec Wheel and I can select one to try and set up. However, none of the controls are responsive top assign or calibrate. I have the wheel set to PC compatibility mode.

I've found a few videos on Youtube that show the solution is to disable one of the two Fanatec Wheel "HID-compliant game controllers" in windows device manager then go ahead and set up the wheel in OMSI 2 and it will work. I have tried that but it doesn't solve my issue. When I do so the Fanatec Control Panel shows the wheel as not being connected and in the game I still cannot get the controls set up (although I'm not down to one Fanatec Steering Wheel entry).

Both videos I found are using other Fanatec wheels and older Fanatec software (Fanalabs and Fanatec Wheel Property Page) rather than the current Fanatec control panel I have...perhaps that is the issue?

It's a bit of an obscure older game, but has anyone had any luck getting this working?

Here are the videos I mentioned: (not in english but easy enough to follow along)




  • I've solved this after a bit more work, posting here in case anyone else has the issue.

    It turns out the solution was indeed to disable one of the fanatec wheel devices in device manager, however in order for this to work I had to put the wheel in PC mode rather than PC compatibility mode which was surprising. All working now and driving OMSI with a 2520 degree steering wheel is glorious :)

Sign In or Register to comment.