Another CSL Load cell pedal causing problems

Yesterday I received my CSL load cell pedal. After installing on my pedal set, I followed all the instructions and double checked the wiring and connected my CSL DD pro setup via USB to my computer. I checked for firmware and everything was OK. As I went to calibrate my load cell pedal my throttle pedal wasn't responding and was staying on 0% when I pressed the throttle down so I rechecked the wiring again.

My CSL DD pro is going to be used mainly for Gran Turismo 7. I tried to play on GT7 and the load cell was working but no throttle. After an hour trying to get both the throttle and load cell to work it began to unexpectedly work! I tried Gt7 again and after 10 minutes my throttle on screen was displaying that it is being pressed 100% and I wasn't even touching the throttle at all. I turned everything off, took the pedal set off my rig once again which is a pain and checked the wiring again. I re-inspected and everything was correctly in place. I tried on the PC again and on the pedal options the throttle input it was fluctuating and flickering from 0 to 100 percent and again the throttle wasn't even being touched.

I decided to reinstall the pedal set how it came originally with my CSL DD pro (Only the throttle and brake pedal without the loadcell pedal) and everything worked perfectly again so the problem was from the load cell pedal itself all along.

What I can say for sure that the load cell felt great but it's a bummer that I can't enjoy it. I contacted support. I hope I can get some help.


  • I feel your pain I got the CSL V3 pedals and my Brakes stopped working after 2 weeks this happened three weeks ago. Same issue as you I installed my stock pedals that came with the CSL DD pro no issue's. My issue is still not resolved and tech support takes forever to respond.

  • Going on 11 days waiting for an RMA.. got the usual silly questions like I am the only one with this same issue.. took 8 days for first response.. Now waiting for my second.. hopefully it won’t take 3 or four responses to get a resolution..

  • Hola a todos tengo problema desde el 18 de marzo que recibí el gt dd pro con freno célula de carga, el pedal acelerador no funciona desde ese día lo instalé todo correctamente se queda acelerado y hay subidas y bajadas constante ahora sigue igual el soporte técnico ni me contestan he mandado muchos email ,ahora me dicen que se pondrán en contacto conmigo y sigo esperando ,he restaurado firmware de todo he reinstalado drivers y todo sigue igual .ayer le quite pedal freno célula de carga y ya ni acelera está muerto se lo volví a poner y empieza a funcionar mal con subidas y bajadas continuas yo creo que el problema está en el pedal de freno célula de carga por lo que sea se lo carga al pedal acelerador ,mientras esto se soluciona estoy usando mis viejos pedales csr y funciona perfectamente,también les comunique a fanatec que los iba a denunciar a la OCU espero me solucionen esto pero no soy el único con este problema cuando se pongan en contacto conmigo quiero un reemplazo pedales y célula de carga todo completo

  • Ayer ya me vino el ticket devolucion los pedales y el kit freno de carga mientras seguiré con los antiguos pedales csr

Sign In or Register to comment.