FanaLab 1.66 (Prev. Public Release) - Post your Feedback here

Marcel PfisterMarcel Pfister Member, Administrator
edited April 2023 in FanaLab

How to report issues:

  • List which hardware, driver and firmware you are using
  • Cross check with other settings, games and wheels to see if it's a general issue or specific with to a game, wheel or setting.
  • Is it happening with just one game (which one) or all you tried.
  • Go into detail how we can reproduce the issue.
  • Post screenshots or videos if needed.
  • In case of a FanaLab crash, use the "Collect Logs" feature under "Settings" and upload them here.

Changelog of FanaLab 1.66

  • Fixed USB-Adapter Device showing up
  • Fixed Wrong Flag LED colors on Formula V2 + old belt bases
  • Fixed Crash when powering off base 
  • Fixed Crash during start when Version.json has wrong formatting
  • Fixed Hint on Steering Wheel Vibration for Wheel Lock
  • Fixed no installed games found after initial install or resetting FanaLab settings during installation
  • Added check if rFactor2 x64\Plugin folder exists
  • Added new FanaLab_Telemetry_support_list.pdf
  • Added 3 new backgrounds. Default background when no background is set is one of the 3 new ones
  • Improved default Formula V2 picture
  • Changed Welcome picture and Banner picture in the installer

Known Issue:

  • Sometimes rev limiter vibration for the steering wheel stays active after once getting triggered.


Driver 443 or higher is required for this FanaLab version:

Only download if you also use driver 443 or higher, as it is required for this FanaLab version.



  • edited August 2022

    As always: For an easy find, attached my most recent profiles, compatible with todays new FanaLab version 1.66 and RC Driver 444.

    Changes since last release: reverted FFB settings for F1 22 profiles. Now again without in game wheel damper as it slowed down steering too much and with more FFB strength again. This means the wheel can oscillate a bit easier again now, but you can countersteer much faster and overall the FFB details are more detailed again.

    No other changes to other game profiles in this version as 1.66 is just a small refinement over 1.65 without significant new features ;)

  • Thanks a lot for your outstanding support. 👌

  • This is why I always tell people to buy Fanatec for the support and profiles, couldn't race without them makes things easy.

  • The rev LEDs get stuck. Like after I switch gears up the LED's will show a set of lights until the range gets passed what's there. Example: I have lights 1-9 assigned to a rpm level, for this example lets say 9 is 10000 and it goes down by 100 each one until light 1. So light 1 is 9200, 2 is 9300 etc. After I go up a gear lights 1-3 will light right away and the rest till show after I passed what light is shown. Sometimes it will be 2 lights, or 1, maybe 5.... And at times all the lights will stay lit after going up or even down a gear until the RPM of the car matches the RPM value of the first light you set. I have tried it with percent mode and same thing. It is not a hardware issue because if I don't use Fanalab and use the games LED feature it does not this.

  • edited August 2022

    Which Base?

    Which Wheel?

    Which game?

    If it's iRacing, which car in the game? Some cars use a very stupid "feature" where the RPM Ranges are different per gear which could explain your issue already.

    Can only imagine you are driving one of the cars in iRacing which use the aformentioned different RPM values per gear "feature" of iRacing where it's normal that the LEDs light up after a gear change because in the next gear the RPM values are different and Fanalab Doesnt support different RPM values per gear (yet).

    Otherwise I never heard of something like this ever before and I cant reproduce this in any other game...

  • Base: DD1 PS4

    Wheel: Formula V2 Podium (Came with the DD1)

    Game: Every game, every car

  • As a side note, I play on PC. I only got the Podium DD1 PS4 for the cool ass steering wheel with the blue handles and open bottom, lol.

  • Also, it does it randomly, not every gear, not every corner. Sometimes for half a lap it will be fine then it will do it a few times for a random period of time. Even the OLED screen on the wheel will flicker whatever it is I have there. The ITM on the base always stays put, that does not glitch out.

  • edited August 2022

    Sounds like a connection issue between the wheel and the base then.

    As said, no issue in any game for anyone else so must be something hardware related I think and the most likely issue is a connection issue in this case.

    Do you use the additional locking screw for the QR already? If no, then try that one.

    Also dont use any USB Hubs but only a straight USB connection to a USB Port of your Mainboard.

  • If it was hardware related, then it will do it without Fanalab right? Because if I do not use Fanalab and use the games rev LEDs it works perfectly. I am going to try uninstalling and reinstalling Fanalab.

  • And I always screw that metal thing till it is tight after putting a wheel on.

  • edited August 2022

    Not necessarily, no.

    Fanalab redreshes the devices when a new wheel gets attached (or when connection was lost and gets reconnected). In this moment LEDs would freeze until triggered again. So exactly your issue.

    Native LEDs work completely different and are therefore not affected.

    I would still bet it's a connection issue. If it would be a FanaLab issue I am sure we would have Seen many more complaints by now but... Not a single other one...

  • In the new F1 22 profile im trying to setup custom LEDs, but when i go into game nothing shows up. I have all the things activated on the Fanalab software. Fanatec LEDs is disabled in game, and UDP Port is the same as well.

    Wheel base: GT DD Pro

    Wheel rim: Clubsport Formula V2.5

    Driver version: 444

    Fanalab version: 1.66

  • edited August 2022

    Please post a picture of the in game Telemetry settings and the Fanalab game profile page

  • Always get the message "Please install Driver Package V442 or higher. Click ok to get the latest version 439." Ofc I already got the latest driver version installed and my previous fanalab version had no issue with it. Already tried to reinstall everything with the same result. Got nothing left I would try tbh.

  • edited August 2022

    And what "latest" driver do you have installed? Usually that message means that you do NOT have the latest driver version installed... ;)

  • Issue is the Broadcast Mode. Has to be set to OFF in order to get FanaLab to work.

    But this would have been set correct automatically when you would have clicked on the two green buttons in the game profile Tab in Fanalab to Enable Telemetry and Enable Fanalab support.

  • I turned broadcast off and it now works, but i had to do it manually. I hit the 2 green buttons again and they didnt turn it off

  • I found the issue. First, I deleted all profiles and wiped Fanalab and all it's files off my PC. Then reinstalled it. Then made my profiles again from scratch. It ONLY does it if you have more than one LED light up on the same RPM value before the redline. Example, LEDs 1-3 show up at 6800, 4-6 6900 and 7-9 7000, the first 2 sets or just the first set will stay lit ONLY if you max out the RPM and trigger the wheel vibration. But it will not do it if a first set of RPM LEDs come on individually. I found this out after so many tests lol

  • If I turn off wheel vibration, it never does it. Interesting.

  • edited August 2022

    Thanks for the Analysis!

    Seems to be related to the Known issue posted in the first post where Rev Limiter vibration can get stuck until they get triggered again, seems this also affects the LEDs then.

    Will forward this info.

    In the meantime, just disable Rev Limiter Steering Wheel vibration as recommended since 1.65 and you should be good to go.

  • Ryan DlugoszRyan Dlugosz Member
    edited August 2022

    Just chiming in to say that I'm also troubleshooting an issue where my wheel (the formula rim that ships w the podium dd1 ps4) locks up - none of the buttons/shifters work, vibration motor gets stuck on. FFB and steering continues to work fine. Wheel buttons are dead until you remove it from the base and reattach.

    I need to run some more test laps but it seems like this only happens while I have Fanalab running. Will post an update once I've run some more laps to verify.

    edit: running the latest beta drivers and FanaLab as of 29 aug 2022

  • edited August 2022

    This sounds like a typical connection issue where for a short time the connection between the Steering Wheel and the Base gets lost and then the inputs on the wheel freeze. Typically this is caused by either too much play, usage of a USB Hub or simply because of a hardware issue of the WQR module which would be a hardware issue and you should contact the support.

  • I am currently going through a hub, so I'll directly connect the dd1 to the PC and see if I'm able to reproduce the issue with or without fanalab.

  • Then chances are that it's "only" the Hub as Hubs can generate several issues like Disconnects etc.

    For the record: it is not recommended to connect any Fanatec product to a USB Hub. If the cable is not long enough then you should better use a USB extension cable (as short as possible as longer cables are also more prone to issues) and rhen directly connect the device to a USB Port of the Mainboard. Only this way the best possible connection is ensured.

  • thx for the tips. So after some more testing it appears the problem is NOT fanalab, nor the usb hub (I'm directly connected now). I think the issue is related to my wheel (the ClubSport SW F1). Within ~5 laps I get a wheel crash.

    When I switch to the round Porsche wheel I can't reproduce the problem (after ~20 laps).

    Possible that it's the wheel hardware, but also suspicious of the 444 driver package as I hadn't had the issue until recently when I upgraded. I'll post a comment in that thread.

  • @Marcel Pfister @Maurice Böschen

    Thanks to both of you for the latest updates & especially Maurice for the updated profiles, all working perfectly with the new Driver 444 and Fanalab 1.66

    Using DD1

    PBME on Porsche wheel

    Podium Paddle Module

    Podium Hub

    CSP V3

    All with lates firmwares.

    Uninstall drivers and Fanalab, reboot, install new driver, reboot, install new Fanalab, reboot, import all iRacing profiles and configure for DD1 works a treat.

    Cheers for all your work, as always it is very much appreciated

    Cheers QuozL

  • Yep. Actually, I'm trying 440 as that's what (I think) I was on prior to 444. Going to try a few combinations of drivers/firmware prior to posting in the 444 thread so that I can provide more useful information (and be relatively sure it isn't just a hardware issue on my end that coincidentally occurred)

This discussion has been closed.