SOLVED: Fanalab: Telemetry is uninitialized for F1 22

Morgan DenoMorgan Deno Member
edited September 2022 in F1 20xx

Hey Everyone,

As the title states, I cannot for the life of me get Fanalab to see the telemetry data from F1 22. Running fanalab v1.66 and driver is at 447

As seen the in screenshots, I should have my telemetry data correct in the game. I've tried different UDP ports and always make sure what I set in game I go and set in Fanalab. See in the error I'm seeing in the bottom left of Fanalab: 'telemetry unititialized'

Other details: Windows 11 (all windows updates done), Fanatec CSL Elite F1 base

Any ideas?


  • The message "Telemetry is uninitialized" on the Main page in FanaLab is normal because the game does not send Telemetry data when it's paused. The game automatically pauses when you Alt+Tab from the game into FanaLab so the uninitialized message is basically always shown. You would need to run the game in windowed mode and then switch to FanaLab so rhe game is not pausing the not get the uninitialized message.

  • Thanks Maurice! Good to know about the error but I still wasn't getting my custom LED lights or display set to Gears primary that I like. I finally got this fixed by using a UDP port 20888 or above. For some reason, it would not work with anything in the 207XX range. Super strange, but I hope this helps someone else if they have the same problem.

  • SOLVED: Maurice pointed out that Fanalab will always show 'telemetry is uninitialized' because every time you leave the game back to the desktop the game pauses and so does telemetry (good to know!). That still left me with the problem of getting data from Fanalab to my wheel. I couldn't get custom shift lights or the display to show gear.

    I finally got it working by using port 20888. I could not get it to work on any ports 207xx. It might be something on my network, but if you have the same problem as me, try a much higher (or lower) UDP port.

Sign In or Register to comment.