DD2 not showing up in Fanatic Driver


i received my dd2 yesterday and wanted to update the firmware immediately after powering it up for the first time.

However the dd2 is not recognized at the fanatic driver. It says not connected.

I could update the CSL Pedals without any problem.

The dd2 itself says the main firmware is 3.0.0. while the motor firmware is v29.0.0.

The fan is running at 100% which indicates apparently that there is a firmware missmatch. However i do not know how to solve this. I would appreciate any kind of help.

Thanks in advance.


  • Marcel PfisterMarcel Pfister Member, Administrator

    Hi Marcel,

    Do I understand correctly that out of the box it was not working and already the first time you've connected it, the fan was running at 100%. Or was it first working normally but you got problems during the first update?

  • Hi Marcel,

    thanks for your quick feedback.

    Out of the box the fan was not on. But also out of the box the wheel base was not showing as connected in the driver. I could only see the pedals in the driver.

    When i went to firmware update he showed the wheelbase. I pressed on update and he started the automatic update process. I believe the driver updated the pedals at first without any problems (pedals are shown as up to date now in the driver).

    During the automated update process the wheelbase restarted and the fan went to 100%. Driver was saying please wait. I waited over 1 hour then closed the updater. Since then wheelbase doesn't show up in driver (not connected) and if i power it on the fan goes to 100%.

    So out of the box it was ok but during the update process something didn't work well. Now it seems Main FW is higher than Motor FW which i can't seem to fix.

  • Marcel PfisterMarcel Pfister Member, Administrator

    The problem is that the motor firmware and base firmware are incompatible but we can get you out of this.

    How to recover from this (just tried out with your exact same situation)

    1. uninstall your current driver
    2. install this older driver linked below
    3. start the base by holding down the power button for 10seconds, this will force a firmware update
    4. after that the base should be working normally, but is on older firmware
    5. install driver 447
    6. flash firmware through the automatic process

  • That worked perfectly.

    Support gave me other information which didn't help. Your guide worked instantly. i am able to use my dd2 now with up to date firmware.

    Thanks a lot.

  • Marcel PfisterMarcel Pfister Member, Administrator

    I'm glad it helped, I'll double check that the support team is completely aware of this solution and when to use it, maybe there was some confusion because its not always easy to pin point what the exact situation is.

  • mark dinsdalemark dinsdale Member
    edited April 2023

    Im having same issue tried all that is listed and it still doesnt work. Install new firmware then it says read the manual. The manual is so bad it doesnt explain nothing so im just stuck with a wheel base that dont even work. Premium product with a cheap tacky driver system yeh sounds about right. My CSL DD never had all these issue was plug in and off it went but nooooo not for the most expensive product that aint been updated since 2019.

  • Hi Marcel,

    I haven't used my rig for about a year and now that I want to use it came to what it seems the same problem with a twist. The Motor firmware is showing FW:v0.0.0. I tried the steps mentioned above but haven't had no luck. Please help!!!

  • It's dead.

    You need to contact the support.

  • It's NOT, it's very much alive... I was able to bring it back to working condition :)

Sign In or Register to comment.