Fanatec Podium DD1 Clubsport Steering Wheel F1 not working correctly.

So I bought Podium Racing Wheel F1® Premium Bundle on 9-11-2022. Two day later i installed everything like it should be. Everything was working until yesterday.

While i was practicing in Time trial of F1 22 on PS5, i noticed after one lap while i had to shift down in gears that is not working. At the same time any button that i tried was not responding so i could do nothing.


I had to turn off my wheel base. While i tried to start it up again after the wheel did the calibriation, both display were black with no information. Then i tried to start it up again.

After second time wheel base turned on en everything seems to work fine again. So i tought maybe i have to udpdate firmware. I work as advanced app developer so those things as updates, reboots, reinstall drivers are very known steps by me. I did everything i could in terms of having all components up to date. After i change mode on wheel from ps4/ps5 to PC.. Wheel, wheel base and pedals were detected without any problem.


In firmware manager i could see that everything is up to date. So i decided to give it a go in F1 22 again. After several laps issue occured again. If i may suggest what i think that theproblem is. I think that the wheel has some hardware issues, because of strange start up after the wheel was not reacting while in the game. It looks like, lag and freezing at the same moment. Because you can see that while i am pressing buttons,,, the Led's on wheel stay in the same position and speed does to. It is strange because steering works and pedals do to while shifting and other buttons on the wheel are not reacting.


I found several people on Forums and youtube who were experiencing same problem. Some of those people had problem after 1 or 2 years of using. Some of them had they stuff not up to date. But in my case.. i really dont think this is software issue.


I uploaded some videos on my Youtube Channel. Those are the links. So you can see for example while i play what happens.

- In this video you can see me sitting in F1 chair, after i had to turn wheel

down while it stoped reacting. Than i turned wheel base on and only black

screen with noise. __ In this video you can see at time 0:29 until then everything is working, and from 0:29 i was talking to my friend. Like this time everything works and as i said it, wheel did not respond any more. You can also notice that when this happens,, speed on wheel seems to be frozen.

-- In this video i was troobleshooting about when in the race occurs this

problem. I tought maybe when i crash or something. But it's really not

consistent in occuring. Sometimes i am on the long straight and when i need to

shift to 8 gear from 7th it wont shift. Sometimes when i brake it wont shift down.

So this is very annoing. I have also some logs files, i am gonna send

those too.


It is not even a month since i bought this set up. And there are allready heavy problems occuring.


So i hope you gonna take care of this asap and please watch the video's i do not think that after you saw the videos. That there wil be any questions.


After seeing and reading things on forum. I sincerly do thing that there is hardware issue and that wheelbase and wheel schould be replaced.


With kind regards,


I did send this message today to the fanatec. Through the support option on their website. I did not receive any "no reply" email from their mail service.. So now i dont know is they have my case. If some from fanatec is reading this, please contact me.

Thank you

Sign In or Register to comment.