Just want to get driver

Upgraded to Win 11... Doesn't recognize base, pedals, or wheel. I just want to download the friggn drivers. When I try, it says "the resource is unavailable so choose another path" or something like that when I unzip and try to run the installer. Nothing works. Fanatec control panel says "nothing found", but if I try the flash firmware it sees it but does nothing at all... Any assistance would be helpful.

CS Base 2.5 / V3 Pedals / Formula Carbon wheel


  • Is there a special way to download drivers? Never had this issue before...

  • Download the latest driver from https://www.fanatec.com/driver, extract the downloaded zip file and Run the msi installer.

    You seem to have some old driver 381 installed, which you should uninstall first.

  • Thank you for the reply as I am desperate! I have tried to do just that. The message you see is what I get after the unzip and starting the installer. I don't have any driver at all is the problem it would seem, because nothing I do will get the base recognized. I can't even get to the repair option.

  • How do I get MSI Installer? Maybe that's the problem... Tried to search, but not much luck to find a download link.. I'm Win 11 64

  • I gave you the link already.


  • My apology sir... I believe I have not explained clearly what my problem is. I have tried that already (just tried again) It downloads the driver, but when I go to open, it gives me what you see above. I incorrectly thought maybe it was an improper download utility? It gives me the option to select, run, the Wizard with default Fanatec wheel folders, but when I approve install, that's when I get the pic above. Sorry to be a pain.

  • edited December 2022

    Do you extract the downloaded zip file?

    You cant run the msi installer through the zip file, first needs to be extracted.

    Also have a look into the installed Apps and programs if the Fanatec Software is installed. If yes, uninstall that old version first.

    Other than that I have no idea what's going on and I would suggest to reinstall Windows from scratch because this is clearly your Windows being screwed.

  • Thanks! I will try all this again Win 11 was just installed. I appreciate your time.

    all the best.

Sign In or Register to comment.