Brand New Podium F1 - Buttons No Response with GT7

Hi All,

I just got my brand new Podium F1 this week and had it installed today to replace the GT DD Pro.

After all properly connected and PS5 powered on, i powered on the wheel base. Screen turns on and wheel went with self calibration.

After the calibration, first issue came out:

After calibration was done, no buttons pm wheel were working. The wheel base was defaulted in PC mode. I can't even change mode as no buttons were working... i tried to take the wheel off, and re-plug it in, now button works. i pressed "change mode" two buttons, mode changed to "Comp 2.5", and again all button stopped working . So i took the wheel off and re-plug it again, button works, and i again pressed "change mode" two buttons, mode finally changed to PS4 and wheel was recognized by PS5.

Then i started to test ride the wheel base bundle for a while, then found out second issue:

that every single time i restarted the wheel base(say you play for 30mins and went out to do something else and back to continue to play), even the base is already in PS4 mode, no buttons were working(wheel base screen properly on, wheel properly done calibration). i can't even confirm torque mode, not mentioning being recognized by PS5 by pressing the PS button. the only way to solve this is, took off the wheel and re-plug it in, then button how i solve the first issue above.

it's very weird...

not sure if i should feel lucky that at least this can be solved by frequently taking off and on the wheel...but i have to say it's very annoying and also disappointed when the item's so pricy. Already feeling regrets that i shud continue to use my GT DD Pro perhaps...

the wheel and its base were just out of its box and first time use today, so no updates/downgrades of firmware were done.

wud appreciate it if anyone can share some thots/solutions on this, thanks so much!


Sign In or Register to comment.