DD2 Fan constantly running, Firmware Manager crashing PLEASE HELP

Looks like a common problem and already tried for a few hours all the possible solutions posted with no luck...

Problem started when I switched from my McLaren V2 wheel to my WRC. Going back to the Mclaren, only low torque would be detected. After trying a few troubleshooting solutions, I got the base to say Hi Torque but now fan is constantly running (even in 50F ambient temperature and not racing). At one point, I was able to get the Base Firmware updated but not the motor hence why the fan is always on.

The Game Controller also does not detect the DD2 base. I removed drivers/firmware and re-install latest version (447 Fanatec and 1.66 Fanalab) several times but ACC does not bind the steering wheel axis (pedals and buttons are binded).

Anytime I tried to update the Firmware, it crashes on me regardless if I try to update them all at once or separately.

To answer the Fanatec Firmware Manager question when it could not complete the Firmware repair:

Tuning Menu is working properly à Yes

What is the color of the LED power indicator à Solid white

Is the wheel base listed on the Game Controller Panel à No

As a last resort, I went back to an older Version (447) with no luck.

See log attached, and thanks in advance for your help.


Sign In or Register to comment.