DD1 not recognized in specific USB port

Hello, I used my DD1 (ps4 compatible) for a year in the same USB 2.0 port and seemingly at random, it stopped being recognized by Fanatec Control Panel. (currently on driver 447 and latest base/rim firmwares for that). It would control the car in iRacing, but none of my dead zones or settings from fanatec control panel were respected.

I tried numerous troubleshooting steps: repairing driver, reinstalling driver, updating driver to 450, rolling back windows updates, using a different USB cable, reseating all of the cables, cycling through compatibility modes (device was recognized at least to tell me it was in the wrong mode when set to Playstation mode), etc. I tried a USB 3.0 port and it didn't not work either.

The only thing that worked was switching to the USB 2.0 port directly next to the one it was using. If I switch back to the original port, the device becomes undetected again. From the best I can tell, the port is working for data and powering other devices.

This isn't really urgent at this point since I have it working again, but I'm curious if I can resolve the issue as if this working port suddenly stops I would be stranded.

Sign In or Register to comment.