ClubSport Shifter SQ V 1.5 not detected by GT7 with Gran Turismo DD Pro Wheel Base

I upgraded my CSL Elite Racing Wheel + CSL Elite Pedals (with loadcell kit) + ClubSport Shifter SQ V 1.5 by replacing the CSL wheelbase with a Gran Turismo DD Pro Wheel Base. I connected everything to the PC and performed a firmware upgrade and calibration. Everything was detected and working fine according to Fanatec Control Panel. The problem is that the ClubSport Shifter SQ V 1.5 is not detected by GT7 in the PS5. It was correctly detected and functional while connected to the CSL wheelbase.

Any ideas?


  • I have the SQ shifter and DD pro works fine w GT7/PS5. As you say control panel recognizes it, only 2 things I can think of is DDPro in blue native mode and connected to right port on DD? GT set for MT i assume

  • I reconnected the setup to my computer and it seems that there is something wrong indeed. At first, the shifter was not identified. I performed a calibration within Fanatec control panel and I am getting the following output:

    Gears are not correctly detected. Any solution to that?

  • Are you moving the lever, or are the inputs coming spontaneously?

  • Nope. Lever is on neutral during all the gif.

  • This is electromagnetic interference. There are parasitic currents that travel up the cable and create the inputs. Sometimes just moving the path of the connecting cable is enough. Ferrite clips might help. If you play on a metal rig, you can try to insulate the gearbox using plastic washers.

  • Thanks for that! The weird thing is that my setup is exactly the same (rig, wheel, pedals and gearbox) as when I used the CSL wheelbase. It started happening since I upgraded to the Gran Turismo DD Pro wheelbase. In any case, I will try your suggestions!

  • FIXED!

    I bought a Fanatec Clubsport USB adapter, changed it to shifter mode and calibrated the shifter.

    Then, I connected the shifter again to the wheelbase and calibrated it again (because it was not recognized at first but still no spontaneous inputs) and it worked.

Sign In or Register to comment.