DD2 Not seen in windows on desktop but seen in laptop

I just purchased a used DD2 and I'm having issues with it connecting to my PC. I hear the connection in windows, but nothing shows up in Fantac Control Panel or what I can see in the USB controllers.

I connected the base to my laptop with the exact same cable and it's no issues, so it's something with my desktop.

When I first got it, I did a firmware update on the laptop as it wasn't connecting to the desktop and after it completed, it worked fine. I properly ran the usb cable and hooked it back up and it hasn't worked sense.

Am I missing something?



  • Never mind, I did this and it seems to be working for now

    Fixed mine tonight! Tried one of the suggestions in this forum.

    Here's what I did:

    1. Unplug all USB except keyboard n mouse

    2. Unplug all fanatec pedals n wheel connected to DD2. No throttle key either.

    3. Turn off DD2

    4. Uninstall Fanatech driver

    5. Reboot PC

    6. Install Fanatec driver 381

    7. Connect DD2 to a different USB port from earlier

    8. Start DD2 on Bootloader mode (press ON for 8 secs)

    9. Launch Fanatec software (the one u get on desktop after installing the driver) and select DD2 device. This opened a dialogue box stating it detected that my Motor firmware was old and I click to update and followed prompts after. Soon my motor firmware was flashed to v40. All is well!

  • Before buying DD2, did you use some Fanatec pedals and use Fanatec CP driver?

  • I have V3 pedals, but I'm not sure what CP Driver is.

    I am still having an issue though. The DD2 seems to only work on one port of my PC (only one of the front panel ports)

    Still works fine on my laptop though

  • CP = Fanatec Control Panel

    so you had the FCP driver installed before because you were using V3.

    I'm not sure what procedure you did, but I believe that you should have first uninstalled the driver in a detailed procedure and then installed everything fresh, so that DD2 goes first.

    I don't know, but apparently something messed up in your win registry.

    maybe try this or new win instal.


Sign In or Register to comment.