Podium Racing Wheel F1 not working.

I bought Podium Racing Wheel F1® Premium Bundle on november 2022. I installed everything like it should be. Updating the wheel base & pedal on a PC. I played only on PS4 because i don’t have a PC gamer. Everything was working until this week. 

While i was practicing in Time trial of F1 22 on PS4, the wheel and the pedal button doesn’t responding anymore after 6 laps. Any button that i tried was not responding so i could do nothing. I turned off the wheel base & turn it on again but it doesn’t resolve the problem. 

I tried to connect the wheel base and the pedal to the PC to make a firmware update but the pc doesn’t recognize the wheel base. Pedal V3 was detected directly. I was on PC mode.

I had to try an hundred time during 2 days while suddently the wheel base was recognize and appears on the fanatec control panel. I updated to firmware 450. 

After updating, i tried to play on the PS4 but after 1 of 2 minute, any button that i tried was not responding so i could do nothing, allthough in the PS4 menu. I launched several games with the PS4 controler with no problem but the wheel base doesn’t work.  The only thing i can do is going in the tuning menu. Picture in attachement.

I tried several time during the week but always the same issue.

I send a message wednesday through the support option on the fanatec website. I did not receive any answer from their technical support. So, i dont know if they have my case.

Somebody know how long do I have to wait to receive an answer?

Can anybody help me please?

Thanks a lot


  • You must receive a standard response via email "Dear Customer, blah blah blah".

    If you have not received this immediate response, the ticket has not been opened.

  • edited May 28

    Thanks for your answer.

    I tried 3 time to open a support ticket but I never receive any response. Is there another way to get in touch with the technical service to have a support?

    I saw on this forum that some people had the same problem with the same wheelbase that they have bought at the same time as I ( Blackfriday ). Maybe a bad series. But nobody say how it was resolve at the end.

    Is there anybody on this forum who had the same problem? If yes, What was the solution offered by Fanatec. I’m a bit worried because I saw that the product is discontinued. So they can’t send me a new one if necessary 😕

  • Did you found a solution for your issue?

Sign In or Register to comment.