Formula V2 with APM bugging out mid race



Wheel 45

QR 6

PC Driver 450. Currently Running 448, but problem still exists making me think it's the Wheel or Base Firmware...

Ever since I updated firmware and upgrade drivers nearly a month ago, my Formula Wheel has a been flipping out. The LED will flicker the gear number between real and "n", and my clutch paddles have not been working.

In iRacing, I have my Bite point set to 50%. At race start, I pull both paddles, drop my right paddle for 50% bite for the start of the race. From there while racing, pulling 1 paddle should go to 100% open clutch. but a single paddle, either of them, only goes to 50%. So iRacing won't let me change gears after race start because it needs to see full clutch. Both clutch paddles work independently, but pulling either one by themselves after race start only brings them to 50% in game.

I tried to fix it by cloning a second profile but with no bite point. After a failed start, I'd switch to setup 2 from the wheel and keep racing. After 2 bad starts, and changing profiles did no fix the clutch bitepoint. I had to completely reset the wheel base mid race.

I've reseated the QR many times, tried racing with my other wheel the Clubsport R300. I've had no issues with the R300 with APM. But the R300 is too heavy for the open wheel cars, and I prefer the lighter V2.

This problem is specific to iRacing where I race a lot, and the major bug occurs specifically after race start. However I have had the bite point kick in mid race once. Reseting the wheelbase seems to fix the problem between races, but if I forget to reset the base after more than 2 races the rear display starts to flicker and I most likely will loose shifts because of the failed bitepoint from using a single clutch paddle.

I'm downloading Beta Driver 451 to see if problem persists

Sign In or Register to comment.