CSL and Clubsport USB Adaptor Not Working

lee connelllee connell Member
edited September 8 in Pedals

Hi all

Windows 11 - Fanatec CSL - Fanatec Clubsport Adaptor

I was given these CSL pedals from a friend (working) - no loadcell just brake and accelerator.

I have a different brand wheel, so I bought a Fanatec USB adaptor to use.

Connecting the pedals I saw input and all working.

Sadly the wheel developed an issue so had to be sent back.

Many weeks after my wheel is now working but for some reason I cannot get the pedals to detect via the Fanatec software (or any game) No luck!

Ive checked the RJ cable and it looks ok. I bought another which I believe is the same but that did not make a difference (https://www.amazon.co.uk/dp/B07YC7DWN5?ref=ppx_yo2ov_dt_b_product_details&th=1)

The USB adaptor is detected and connects and updates ok but the pedals do not.

The brake is connected to the brake socket (not clutch)

The RJ is connected to Loadcell/Wheelbase connector Usb Adaptor PC directly (have tried different ports and powered hub)

Have tried uninstalling drivers - old driver version as per fanatec CSL pedals page on website

Latest driver 451

Firmware 1.1

Any ideas on what to try next - I dont believe they are worth fixing from Fanatec but was just wondering if I have missed anything?

What should the adaptor / pedals look like in Device Manager? (I hear a tone when plugging them in but cannot see a reference in there)

Thanks in advance

Sign In or Register to comment.