CSL Elite Steering Wheel McLaren GT3 V2 - Firmware 0, no firmware file found

I just received my CSL Elite Steering Wheel McLaren GT3 V2 today. I attempted to install it on my DD+ (DD Extreme). At first, it just said there was a firmware update for it, so I went ahead and started the update. Strangely enough, though, it said my wheel was at Firmware 0, and that v47 was available.

Now, I'd already turned off power management for the internal USB hub, and I was making sure my computer wasn't idle. I also didn't turn off or unplug anything, nor did I attempt to change modes on the DD+ or hit any buttons/switches on the wheel.

I went ahead and tried the update, like all the other devices before it (everything else was up-to-date). This time, though, it said "firmware file not found".

I tried manually updating it, but the file I have is a .hex file, and the file required is a .eff file. It wouldn't take the .hex.

I've tried the 456 and the 454 driver packs with their own firmware updaters, but each said the same thing.

I've uninstalled everything and blew out everything dealing with any of the Fanatec devices in Device Manager before reinstalling 455 fresh.

I've tried different USB ports and different computers altogether.

No matter what, it looks like the wheel was shipped with a corrupted firmware, and the firmware updater can't fix it - even manually.

Am I hosed? Is this a straight-up RMA? Or is there some way to get this figured out?

Also, the little display on the wheel is inactive at all times.


  • I have the same problem with a formula v2.5x I write to support 10days ago and not response

  • Same happened to me today after updating the wheel base to fanatec driver 456

    Went to update the wheel after and it looks like the update has finished but then the firmware updater shows v47 available for download

    Wheel still works though

    CSL DD 8nm

    Mclaren Gt3

  • You're lucky. My wheel never worked, and still doesn't.

  • I believe they're saying it's a two-week minimum wait for responses now.

  • To all affected by this issue of wheel firmware showing v0 and / or Showing v0 even after saying it was updated to v47, I believe this is a known issue (Comfirmed by Maurice) and so long as wheel work normally otherwise to ignore the issue until there is an update to the Fanatec Driver / Wheel FW to fix this issue.

  • Except my wheel doesn't work normally otherwise. It never did. It immediately reported as Firmware 0, never was able to update, and never worked. I can't even manually update it, as the updater thinks it needs an EFF file when Maurice swears it needs a HEX file.

    I cannot ignore the issue, as my wheel simply doesn't work.

  • 1) Put Fanatec updater in to "Manual Update mode" with a tick in the box.

    2) When you try to do a manual update to the Wheel FW, you shouldn't have to select any .hex or .eff files as it should default to the correct FW version that is included in the Driver package and matches you wheel (The mis-reporting of Wheel firmware v0 may be affecting this detection though).

    3) Just press the "Flash button" in the log output window which is showing the stages of the update process.

    4) If wheel FW is successfully programmed it may work but still report as v0 instead of v47.

    5) If wheel FW is not successfully programmed and / or is malfunctioning then most likely your wheel is faulty and needs Fanatec RMA.

    1. I did that.
    2. That didn't happen. It said the file was not found. I even supplied the correct file after that, but it was a HEX file and therefore not accepted.
    3. and 4. Don't apply.
    4. Can't get an RMA until they get back to me on my ticket. Their minimum response time is now stated to be two weeks.

  • MadDog-ICMadDog-IC Member
    edited February 28

    Ok, I have seen multiple .HEX and .EFF in the folder (c:\Program Files\Fanatec\Fanatec Wheel\fw\, and sub-directory PreviousFirmwares from the fw directory) on my own setup, but none of them indicate what they are related to, so dangerous to load any not knowing whether they are for just a wheel, base, Motor or WQR.

    You could post you complete Fanatec LOGs so others might be able to see if there any clues there.

    So I will leave it at that then, I can't help any more, good luck with it all.

  • If your steering wheel doesn't have firmware, it's not even a steering wheel anymore. Firmware doesn't just contain the code to operate the device, it is the identity of the device itself.

    When you connect the steering wheel, wheelbase through the pins, reads the identity code of the steering wheel, which is written in the firmware. This is why updating the firmware is considered an extremely dangerous operation, not recommended by all manufacturers, except Fanatec. Without firmware it is no longer a PC peripheral, and if it is no longer a PC peripheral, you will not be able to use the PC to install new firmware.

    You can only wait for Fanetec to reply to you.

  • I know exactly what firmware is. Thank you for trying to explain it to me, though. As for updating firmware, many manufacturers have the user update it. Printers, multifunction office machines, and laptops are notorious for this. Phones and videogame consoles also do this. This is not a Fanatec-specific thing.

    That said, Fanatec's own moderators have said there are issues with regard to the control panel software reading the firmware of a wheel with the current drivers. I expect Fanatec will run me through a series of hoops regarding that before allowing me to RMA it.

  • Maurice posted the actual HEX file for the wheel in question. That's the one I'd attempted to use. I obviously wouldn't attempt to randomly grab one of the myriad files for the attempt.

    He had even said that the updater should see that the wheel uses HEX files and should allow it, and that since it doesn't, it needs to be fixed.

Sign In or Register to comment.