Help with main forum account login and RMA?


Would you be able to help me with my main account? Every time I tried to log into the forum, it made me log in from the main page. Once done, I go back to the forum, and it shows my name with Sign in next to it. Once I click sign in, it says the account has no name (even though it’s listed) and no password. (Forum password reset doesn’t work). Do you have any tips for getting my main account to work?

For USA RMA, are repairs still being done in Cali, or is it in Texas? It was requested that I send my base to the California repair center in January—still no updates on its whereabouts nor the repair status after Fanatec confirmed they received it. Any escalation on this is appreciated.


  • i have today the same scenario. i go to main page log in and then select here in forum my name and it send me back to login. after new log in i could login here on the forum.

  • I wished it was the case. I kept getting this loop.

  • cody mcody m Member

    I finally made it into forums.

    I had this same loop like forever and gave up.

    Today I got in by making a completely different account. I literally used a different device and info to sign up, ridiculous

    Hope it help someone

Sign In or Register to comment.