Does pedal calibration reset every time you unplug USB or turn off computer? Elite V2, mine do. HELP

edited May 13 in Pedals

I have tried and nearly given up at this point. I have tried both through CSL DD, DD+, USB stand alone (current mode) and no matter what I do, it ALWAYS resets my calibration data requiring that I calibrate before any session (after computer reboot or disconnecting/reconnection pedals). I thought it was my base so now I have been running it in USB mode and no difference.

One thing I noticed in USB mode (now that firmware data shows up) is that it's showing

PC DRIVER 457 (I have uninstalled and tried 455, 456, same thing)

FIRMWARE

Pedals : 0

hmmm? Is that my issue? I updated them some time (not many updates for CSL Elite V2s) and they've always just worked (minus the calibration saving issue)... could this be the cause?

when I go to "FIRMWARE UPDATE" it says New Pedal Firmware Available 1.6 (for my pedals).

When I open "FIRMWARE MANAGER" it says:

"CSL Elite Pedals V2 Firmware: 1.6

"Firmware is up to date"

so which is it? is it up to date or is it not?

Or is this just a glitch with 457? It's so hard to tell because some versions of Control Panel had faults and showed no firmware data so I never know.

Please help, having to calibrate every session (because I turned off my PC or unplugged pedals USB port) is not only annoying but it's hard to get them exact every time!

Anyone have this issue and found a solution?

Comments

  • edited May 13

    1.6 is the most recent Firmware.

    That the Control Panel shows v0 is a cosmetic driver issue without any relevance to be fixed with driver 458 or 459.

    That BRF gets reset is a known Firmware issue to be fixed sometime in the future, absolutely no ETA for this yet. It's known for quite some time though.

  • I understand BRF gets reset, if that was the only issue, Fanalab takes care it anyways. But it's not just BRF for me, entire calibration gets reset, requiring that I start over and recalibrate every time. Is that a known issue as well?

  • No, thats highly unusual.

  • edited May 14

    Thanks Maurice, I'll bite the bullet and reflash the 1.6 firmware and recalibrate to see if it starts to stick. Was just avoiding this process if it was already 1.6. WIll provide update later if that resolves the issue.

Sign In or Register to comment.