FanaLab 1.69.7 Public Release (prev. 1.69.1) - Post your Feedback here



  • Maurice, Skippy in iRacing used to have a white flashing LEDs enabled when approaching the rev limiter... they seemed to be turned off now.. was this intentional? thanks!

  • You all I have spent nearly 3 days attempting to figure out how to bind profiles to cars in Fanalab with the new CDALP perk. Maurice, sorry for asking for seemingly nonsensical help at odd hours, especially considering the time difference from there and the States, and thank you for having patience like Santa Clause. Anyhow everybody, if you can assist me with any leads I will greatly appreciate it.

    I have a DD1 using the Universal Hub fur Xbox V2, all the latest drivers on base and wheel. Fortunately I think I have been attempting the process correctly all along, but for an unknown error code of a reason, ProfileCarsList_AMS2.xml is not copying over correctly to C:\Users\[USERNAME]\AppData\Local\Fanatec\FanaLab\xml. I will attempt to upload a photo of the error code. I believe it is the culprit as to why Fanalab is crashing when I open AMS2 in my Game Profile tab in Fanalab. The CarList_AMS2.xml file does fine transfering over, and of course I have found out that I can load the profiles individually and manually, but obviously for convenience I sure would like the profiles to switch over in-game. Please help me on this if anyone can. Any and all and Maurice, Thank you much.

  • "ProfileCarsList_AMS2.xml is not copying over correctly" -> As I have explained already, please do NOT copy/paste the whole file but only the CONTENT of the file. For this you need to open the xml files with a Notepad / Editor, not with your Internet Browser as shown in your screenshot.

    "The CarList_AMS2.xml file does fine transfering over" -> Which CarList_AMS2.xml file? I do not provide a CarList_AMS2.xml file in my profile pack. I only provide a CarList_AMS2_Custom.xml file with my pack. When you try to copy/paste the content of the CarList_AMS2_Custom.xml file into the CarList_AMS2.xml file then its clear that FanaLab will crash as this can not work because those are two completely different files.

    As we discussed on Facebook yesterday already I highly suggest that you do not try to mess with the xml files at all but binding the cars to the profiles completely by yourself. This is easy, straightforward and only takes 2 minutes. Its explained in the first post of this thread how to manually bind cars to a profile. You should try that (after you completely uninstalled FanaLab, deleted everything related to FanaLab in the AppData and Program Files (x86) folders and then re-installing FanaLab fresh with the checkbox checked to reset all settings to default.

  • Casey WykesCasey Wykes Member
    edited January 2023

    Hi, Maurice. I believe I am only copying the content, not the file, I only used the browser to show the error code it's pulling up when checking the file after pasting and saving it with Notepad, and I accidentally typed car list without "custom" in my last post, a typo on my part. I am pretty sure I am doing this correctly, and when I remove what I copy and pasted from the profiles car list Fanalab does not crash. I am in VR so would rather not have to load a different profile manually any time I want to switch cars. I'm pretty sure I have been doing this right, at least for the past day and a half, just am not sure what the column and line error code are. If I am able to switch from car to car in game with their respective profiles by merely manually binding them then I will happily give up this chase. If not, I would still like to find out how to utilize this feature. Thank you for the help, I hope it can work out.

  • edited January 2023

    You can bind cars to profiles in 2 minutes by yourself without needing to fiddle around with xml files so afterwards you no longer need to manually load the profile, that's what I meant.

    Just open the Cars List in FanaLab with the Car icon in the top row, select the car, select the profile, click add car to profile, done. As explained in the first post. Do that for every car which takes just 2 minutes or so anf you no longer need to do anything with a xml file which obviously is just not working for you so you have to bind the cars to the profiles on your own.

  • That's great to read, wish I would have interpreted that correctly in the first place, as I'm so certain you do as well. I sincerely apologize for putting you through this with me.. Thank you again, Maurice. Since this is the case, what is the point of having the "Load" profile button?

  • edited January 2023

    Not everyone wants to use car specific profiles which load via CDALP so these people can "load" a specific profile they created manually.

  • Hello can anybody helpme with Rfactor2 and de rev leds. I have installed the latest fanaleb 1.69.2 and have driver 447 installed. Till yesterday no problems . Now de led does not work any more only in Rfactor2 .

    F12022 it works ACC it works AMS2 it works

    I puth the dll file from fanalab in the bin64 plugin folder buit no effect

    can some one help me

  • You need to click the two green buttons in the game profile Tab in Fanalab to Enable Telemetry and Enable Fanalab support.

  • yess I have don that already and then he said that it is correct and working when I am in Rfactor de plugin is visible and on

    when I run in comp mode or Pc with the wheel base no effect very strange

    before the update I run the 1.57 fanalab with the 447 driver and it worked

  • what can I do?

  • I had completly delete en install fanalab and the game no help

  • Please post Screenshots of the two pop-ups you get shown when you click the two green buttons in the game profile Tab in Fanalab to Enable Telemetry and Enable Fanalab support.

  • Does it something to do with ITM. I can select that in de bottom left by profiles

    does it work in pc mode with the new fanalab version in the old onze it does

  • Also in comp mode it does not work

  • edited January 2023

    As I said, please post Screenshots of the two pop-ups you get shown when you click the two green buttons in the game profile Tab in Fanalab to Enable Telemetry and Enable Fanalab support.

    Has nothing to do with ITM, You dont have a ITM compatible device (Podium DD or BME).

  • You mean this?

  • And when I look in the plugin folder of rfactor2 There are both the correct dll files from fanalab.

  • "both" dll files?

    There is only one dll file supposed to be in the rF2 install folder: The PodiumrFactor2Plugin64.dll which needs to be in the Bin64\plugins folder.

    When you entered the correct controller profile name in the second step of the green button activation (the one where you enable FanaLab support - this is the step where most people make issues where they enter a wrong controller profile name and just take the preset which is written there by default) then I dont know anymore, working fine for me so its not a game or general FanaLab issue but something is wrong with your installation...

  • Now after na new install of the game I had the same profile name as in de game Fanatec CSW v.2.5 and in the folder There is excactly one PodiumFactor2plugin64 file and it does not work 😞

    acc f12022 and AMs2 works fine strange

  • This is how it looks

  • And thats pcmode

  • That could be your issue.

    You have a GT DD PRO, not a CSW V2.5 so you should also use the corrr t in game preset for your device (or create a new one) and then enter THAT Name in the FanaLab field (of course the names need to match and you need to re-load the in game profile again).

  • In that picture the dll file is dated from 21st February 2022. The most recent dll file version however is dated 22nd December 2022 and ONLY that new dll file is compatible with the new FanaLab version so THAT is your issue: you simply did not used the new dll file. So delete that file, click the "Enable Telemetry" button again so the "new" dll file gets copied into that folder and then it should work.

    Alternatively, go to C:\Program Files (x86)\Fanatec\FanaLab\control\plugin and copy/paste the dll file manually to the rF2 install folder.

This discussion has been closed.